cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (CLOUDSTACK-9349) Unable to detach root volume when using Hypervisor Type KVM
Date Wed, 20 Apr 2016 05:38:25 GMT


ASF GitHub Bot commented on CLOUDSTACK-9349:

Github user koushik-das commented on the pull request:
    @dmabry Thanks for the fix. I ran it on simulator and it worked as expected. So +1 on
the changes. Although it existed for XenServer and Vmware, I am trying to understand the use
case for this. Is it used for root disk recovery by attaching it to a new VM?

> Unable to detach root volume when using Hypervisor Type KVM
> -----------------------------------------------------------
>                 Key: CLOUDSTACK-9349
>                 URL:
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Volumes
>    Affects Versions: 4.5.1, 4.6.2, 4.7.1, 4.8.0, 4.9.0
>         Environment: Centos 7
>            Reporter: Simon Weller
>            Priority: Minor
>             Fix For: 4.7.2
> Back in 4.5, support was added in CLOUDSTACK-6284 for detaching root volumes. The original
support was meant to work with Xen, VMware and KVM.
> After chatting with fuflo in the Cloudstack irc channel, it was pointed out that a constraint
was not correctly modified in to allow the detach to occur when
vm.getHypervisorType() == HypervisorType.KVM.
> This is a very useful feature, as it allows us to simulate a snapshot revert with Ceph
by using createVolume sourced from a snapshot, then detaching and reattaching the root volume
(new root volume needs to be attached as device=0).
> I'm going to propose a PR for this shortly

This message was sent by Atlassian JIRA

View raw message