cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9289) [Automation] deploy vm from vm snapshot
Date Wed, 27 Apr 2016 18:35:13 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9289?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15260695#comment-15260695
] 

ASF GitHub Bot commented on CLOUDSTACK-9289:
--------------------------------------------

Github user swill commented on the pull request:

    https://github.com/apache/cloudstack/pull/1417#issuecomment-215184791
  
    @nitt10prashant I have to admit, I am confused on this one.  I have the latest Marvin
installed that is generated when building this PR.
    
    ```
    Installing Marvin
    DEPRECATION: --allow-external has been deprecated and will be removed in the future. Due
to changes in the repository protocol, it no longer has any effect.
    Processing ./tools/marvin/dist/Marvin-4.9.0-SNAPSHOT.tar.gz
    Requirement already up-to-date: mysql-connector-python>=1.1.6 in /usr/lib/python2.7/site-packages
(from Marvin===4.9.0-SNAPSHOT)
    Collecting requests>=2.2.1 (from Marvin===4.9.0-SNAPSHOT)
      Downloading requests-2.9.1-py2.py3-none-any.whl (501kB)
        100% |████████████████████████████████|
501kB 1.4MB/s 
    Collecting paramiko>=1.13.0 (from Marvin===4.9.0-SNAPSHOT)
      Downloading paramiko-1.16.0-py2.py3-none-any.whl (169kB)
        100% |████████████████████████████████|
174kB 3.1MB/s 
    Requirement already up-to-date: nose>=1.3.3 in /usr/lib/python2.7/site-packages/nose-1.3.7-py2.7.egg
(from Marvin===4.9.0-SNAPSHOT)
    Collecting ddt>=0.4.0 (from Marvin===4.9.0-SNAPSHOT)
      Downloading ddt-1.0.1-py2.py3-none-any.whl
    Collecting pyvmomi>=5.5.0 (from Marvin===4.9.0-SNAPSHOT)
      Downloading pyvmomi-6.0.0.2016.4.tar.gz (216kB)
        100% |████████████████████████████████|
225kB 2.7MB/s 
    Collecting netaddr>=0.7.14 (from Marvin===4.9.0-SNAPSHOT)
      Downloading netaddr-0.7.18-py2.py3-none-any.whl (1.5MB)
        100% |████████████████████████████████|
1.5MB 614kB/s 
    Collecting ecdsa>=0.11 (from paramiko>=1.13.0->Marvin===4.9.0-SNAPSHOT)
      Downloading ecdsa-0.13-py2.py3-none-any.whl (86kB)
        100% |████████████████████████████████|
92kB 2.5MB/s 
    Requirement already up-to-date: pycrypto!=2.4,>=2.1 in /usr/lib64/python2.7/site-packages
(from paramiko>=1.13.0->Marvin===4.9.0-SNAPSHOT)
    Collecting six>=1.7.3 (from pyvmomi>=5.5.0->Marvin===4.9.0-SNAPSHOT)
      Downloading six-1.10.0-py2.py3-none-any.whl
    Building wheels for collected packages: Marvin, pyvmomi
      Running setup.py bdist_wheel for Marvin ... done
      Stored in directory: /root/.cache/pip/wheels/7f/5a/37/7f723796f0a05b8f4a5eb63ebe90f381663e638e7556f46916
      Running setup.py bdist_wheel for pyvmomi ... done
      Stored in directory: /root/.cache/pip/wheels/b8/4a/84/b57aa91d338fdb54c766ef9d3c4b8d7c7a9f6b0da53e7b112d
    Successfully built Marvin pyvmomi
    Installing collected packages: requests, ecdsa, paramiko, ddt, six, pyvmomi, netaddr,
Marvin
      Found existing installation: requests 2.6.0
        DEPRECATION: Uninstalling a distutils installed project (requests) has been deprecated
and will be removed in a future version. This is due to the fact that uninstalling a distutils
project will only partially uninstall the project.
        Uninstalling requests-2.6.0:
          Successfully uninstalled requests-2.6.0
      Found existing installation: ecdsa 0.11
        DEPRECATION: Uninstalling a distutils installed project (ecdsa) has been deprecated
and will be removed in a future version. This is due to the fact that uninstalling a distutils
project will only partially uninstall the project.
        Uninstalling ecdsa-0.11:
          Successfully uninstalled ecdsa-0.11
      Found existing installation: paramiko 1.12.4
        Uninstalling paramiko-1.12.4:
          Successfully uninstalled paramiko-1.12.4
      Found existing installation: six 1.9.0
        Uninstalling six-1.9.0:
          Successfully uninstalled six-1.9.0
    Successfully installed Marvin-4.9.0-SNAPSHOT ddt-1.0.1 ecdsa-0.13 netaddr-0.7.18 paramiko-1.16.0
pyvmomi-6.0.0.2016.4 requests-2.9.1 six-1.10.0
    ```
    
    I get the same result I got before, so I tried to install it manually to make sure everything
was setup.
    
    ```
    # pip install --upgrade /data/git/cs1/cloudstack/tools/marvin/dist/Marvin-*.tar.gz
    Processing /data/git/cs1/cloudstack/tools/marvin/dist/Marvin-4.9.0-SNAPSHOT.tar.gz
    Requirement already up-to-date: mysql-connector-python>=1.1.6 in /usr/lib/python2.7/site-packages
(from Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: requests>=2.2.1 in /usr/lib/python2.7/site-packages
(from Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: paramiko>=1.13.0 in /usr/lib/python2.7/site-packages
(from Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: nose>=1.3.3 in /usr/lib/python2.7/site-packages/nose-1.3.7-py2.7.egg
(from Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: ddt>=0.4.0 in /usr/lib/python2.7/site-packages (from
Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: pyvmomi>=5.5.0 in /usr/lib/python2.7/site-packages
(from Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: netaddr>=0.7.14 in /usr/lib/python2.7/site-packages
(from Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: ecdsa>=0.11 in /usr/lib/python2.7/site-packages (from
paramiko>=1.13.0->Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: pycrypto!=2.4,>=2.1 in /usr/lib64/python2.7/site-packages
(from paramiko>=1.13.0->Marvin===4.9.0-SNAPSHOT)
    Requirement already up-to-date: six>=1.7.3 in /usr/lib/python2.7/site-packages (from
pyvmomi>=5.5.0->Marvin===4.9.0-SNAPSHOT)
    Building wheels for collected packages: Marvin
      Running setup.py bdist_wheel for Marvin ... done
      Stored in directory: /root/.cache/pip/wheels/7f/5a/37/7f723796f0a05b8f4a5eb63ebe90f381663e638e7556f46916
    Successfully built Marvin
    Installing collected packages: Marvin
      Found existing installation: Marvin 4.9.0-SNAPSHOT
        Uninstalling Marvin-4.9.0-SNAPSHOT:
          Successfully uninstalled Marvin-4.9.0-SNAPSHOT
    Successfully installed Marvin-4.9.0-SNAPSHOT
    ```
    
    I ran it again with the same result.  
    
    For the record, I don't see this command being added in this PR, just the tests to test
it.  Were there other files that were supposed to be added in this PR that didn't get in?


> [Automation] deploy vm from vm snapshot
> ---------------------------------------
>
>                 Key: CLOUDSTACK-9289
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9289
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Automation
>            Reporter: prashant kumar mishra
>            Assignee: prashant kumar mishra
>
> Automating test cases for feature "Deploy vm from vm snapshot"
> FS:
> ==
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Deploy+instance+from+VM+snapshot
> test case result
> ============
> create volume from vmshnapshot and verify usage ... === TestName: test_01_create_volume_from_vmsnapshot
| Status : SUCCESS ===
> ok
> create volume from vm snapshot and download ... === TestName: test_02_create_volume_from_vmsnapshot
| Status : SUCCESS ===
> ok
> create volume from snapshot and attach to vm ... === TestName: test_03_create_volume_from_vmsnapshot
| Status : SUCCESS ===
> ok
> Test to create VM from vm snapshots without data disk ... === TestName: test_01_create_vm_from_vmsnapshots
| Status : SUCCESS ===
> ok
> deploy vm from snaphsot , ssh and verify data ... === TestName: test_02_create_vm_from_vmsnapshots_and_verify_data
| Status : SUCCESS ===
> ok
> Seed template and then deploy vm and check if time ... === TestName: test_03_seed_template_from_vmsnapshot
| Status : SUCCESS ===
> ok
> ----------------------------------------------------------------------
> Ran 6 tests in 1781.242s
> OK



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message