cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9053) CloudStack is dependent upon a vulnerable version of Commons Collections
Date Fri, 20 Nov 2015 19:56:11 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9053?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15018672#comment-15018672
] 

ASF subversion and git services commented on CLOUDSTACK-9053:
-------------------------------------------------------------

Commit b3b56e2cd84a7d716735c4b684f271247192dff3 in cloudstack's branch refs/heads/master from
[~remibergsma]
[ https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;h=b3b56e2 ]

Merge release branch 4.6 to master

* 4.6:
  CLOUDSTACK-9053 security upgrade as per COLLECTIONS-580
  CLOUDSTACK-9055: fix NPE in updating Redundant State of VPC networks
  CLOUDSTACK-9057 remove old system vm upgrade code


> CloudStack is dependent upon a vulnerable version of Commons Collections
> ------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-9053
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9053
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: John Kinsella
>
> COLLECTIONS-580 was brought to our attention today. Current versions of Apache Commons
Collections contain a serialization/unserialization vulnerability which may result in remote
code execution.
> CloudStack does not seem to use the specific vulnerable class InvokerTransformer, so
in theory we could recommend pulling that class from the jars/wars, but still looking to see
what else we can do...



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message