cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Kinsella (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-9053) CloudStack is dependent upon a vulnerable version of Commons Collections
Date Wed, 18 Nov 2015 21:52:11 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-9053?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

John Kinsella updated CLOUDSTACK-9053:
--------------------------------------
    Security: Public  (was: Non-Public)

> CloudStack is dependent upon a vulnerable version of Commons Collections
> ------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-9053
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9053
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>            Reporter: John Kinsella
>
> COLLECTIONS-580 was brought to our attention today. Current versions of Apache Commons
Collections contain a serialization/unserialization vulnerability which may result in remote
code execution.
> CloudStack does not seem to use the specific vulnerable class InvokerTransformer, so
in theory we could recommend pulling that class from the jars/wars, but still looking to see
what else we can do...



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message