cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-9025) Unable to deploy VM instance from template if template spin from linked clone snapshot
Date Wed, 04 Nov 2015 05:17:27 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-9025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14988899#comment-14988899
] 

ASF GitHub Bot commented on CLOUDSTACK-9025:
--------------------------------------------

GitHub user anshul1886 opened a pull request:

    https://github.com/apache/cloudstack/pull/1030

    CLOUDSTACK-9025 : [Xenserver] Sending template creation from snapshot command to Hypervisor

    https://issues.apache.org/jira/browse/CLOUDSTACK-9025
    
    In this fix we are sending command to hypervisor only if hypervisor version is not 6.1.0
and 6.2.0 without XSHotFix62ESP1004. I am not sure whether we support Xenserver 6.1.0 and
6.2.0 without XSHotFix62ESP1004. This conditional check is there to make sure users are able
to upgrade in transition period. If that's not the case we can remove condition all together
and can send command to hypervisor.
    
    To test this issue we need different versions of XenServer. Versions which we are mentioning
in condition in that case it should go to SSVM and in other cases it should go to Hypervsior.
SSVM can't handle linked snapshots in case of XenServer. 

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/anshul1886/cloudstack-1 CLOUDSTACK-9025

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/cloudstack/pull/1030.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1030
    
----
commit 2251751177b6cb66a7e7682ada9ac83ee06a55e2
Author: Anshul Gangwar <anshul.gangwar@citrix.com>
Date:   2015-10-28T09:15:52Z

    CLOUDSTACK-9025 : [Xenserver] Sending template creation from snapshot command to Hypervisor
    if hypervisor version is not 6.1.0 and 6.2.0 without XSHotFix62ESP1004.

----


> Unable to deploy VM instance from template if template spin from linked clone snapshot
> --------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-9025
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-9025
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: XenServer
>    Affects Versions: 4.5.2
>         Environment: XenServer 6.5
>            Reporter: Anshul Gangwar
>            Assignee: Anshul Gangwar
>            Priority: Critical
>             Fix For: 4.6.0
>
>
> As default, CloudStack create linked clone snapshot for VM instance . When we take a
snapshot for the VM, and create a template based on such snapshot, CloudStack only download
incremental VHD as template file, as a result, the VM instance fail to deploy as it is incomplete.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message