cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anton Opgenoort (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-8945) rp_filter=1 not set on VPC private gateway initially, but is set after restart of VPC router
Date Mon, 12 Oct 2015 14:05:05 GMT
Anton Opgenoort created CLOUDSTACK-8945:
-------------------------------------------

             Summary: rp_filter=1 not set on VPC private gateway initially, but is set after
restart of VPC router
                 Key: CLOUDSTACK-8945
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8945
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: Virtual Router
    Affects Versions: 4.4.4
            Reporter: Anton Opgenoort


(on ACS4.4.4 with XenServer as hypervisor)
Steps to reproduce:
-create VPC router
-Create private gateway on VPC router
-now log on to the rVM via the hypervisor's link-local address
root@r-46771-VM:~# sysctl net.ipv4.conf.eth2.rp_filter
net.ipv4.conf.eth2.rp_filter = 0

Restart the rVM via CloudStack (NOT restart VPC but restart the underlying router via CloudStack)

-log on again:
root@r-46771-VM:~# sysctl net.ipv4.conf.eth2.rp_filter
net.ipv4.conf.eth2.rp_filter = 1

The issue thus is that on initial creation it is not set, where it should be set immediately


Note: when adding a regular network tier to the VPC config, that new interface IS configured
with rp_filter=1. So it is limited to the private gateway NIC. 




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message