cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8832) Update Nuage VSP plugin to work with Nuage VSP release 3.2
Date Mon, 26 Oct 2015 18:19:27 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8832?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14974745#comment-14974745
] 

ASF GitHub Bot commented on CLOUDSTACK-8832:
--------------------------------------------

Github user jburwell commented on a diff in the pull request:

    https://github.com/apache/cloudstack/pull/801#discussion_r43031640
  
    --- Diff: plugins/network-elements/nuage-vsp/src/com/cloud/agent/api/manager/SupportedApiVersionCommand.java
---
    @@ -17,38 +17,42 @@
     // under the License.
     //
     
    -package com.cloud.agent.api.guru;
    +package com.cloud.agent.api.manager;
     
     import com.cloud.agent.api.Command;
     
    -public class ReleaseVmVspCommand extends Command {
    +public class SupportedApiVersionCommand extends Command {
     
    -    String _networkUuid;
    -    String _vmUuid;
    -    String _vmInstanceName;
    +    private final String _apiVersion;
     
    -    public ReleaseVmVspCommand(String networkUuid, String vmUuid, String vmInstanceName)
{
    +    public SupportedApiVersionCommand(String apiVersion) {
             super();
    -        this._networkUuid = networkUuid;
    -        this._vmUuid = vmUuid;
    -        this._vmInstanceName = vmInstanceName;
    +        this._apiVersion = apiVersion;
         }
     
    -    public String getNetworkUuid() {
    -        return _networkUuid;
    +    public String getApiVersion() {
    +        return _apiVersion;
         }
     
    -    public String getVmUuid() {
    -        return _vmUuid;
    +    @Override
    +    public boolean executeInSequence() {
    +        return false;
         }
     
    -    public String getVmInstanceName() {
    -        return _vmInstanceName;
    +    @Override
    +    public boolean equals(Object o) {
    +        if (this == o) return true;
    +        if (o == null || getClass() != o.getClass()) return false;
    +
    +        SupportedApiVersionCommand that = (SupportedApiVersionCommand) o;
    +
    +        if (_apiVersion != null ? !_apiVersion.equals(that._apiVersion) : that._apiVersion
!= null) return false;
    +
    +        return true;
         }
     
         @Override
    -    public boolean executeInSequence() {
    -        return false;
    +    public int hashCode() {
    --- End diff --
    
    This ``hashCode`` implementation should include attributes from the ``Command`` super
class.


> Update Nuage VSP plugin to work with Nuage VSP release 3.2
> ----------------------------------------------------------
>
>                 Key: CLOUDSTACK-8832
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8832
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.6.0
>            Reporter: Nick Livens
>            Assignee: Nick Livens
>         Attachments: nuageVspMarvinLogs.tar.gz
>
>
> Nuage VSP 3.2 is being released, we want to bring the plugin up to date for this release



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message