cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noel D. Kendall (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-8920) KVM agent cannot communicate with server on port 8250
Date Mon, 28 Sep 2015 18:50:05 GMT
Noel D. Kendall created CLOUDSTACK-8920:
-------------------------------------------

             Summary: KVM agent cannot communicate with server on port 8250
                 Key: CLOUDSTACK-8920
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8920
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: Install and Setup
    Affects Versions: 4.5.2
         Environment: CentOS 6.7, OpenJDK 1.7.0
            Reporter: Noel D. Kendall
            Priority: Blocker


Attempting to add a KVM host, the management server is able to reach the target host via SSH
and successfully changes agent.properties, and restarts the agent process. All that works
fine. Zone, Pod and Cluster are configured successfully.

Problem is occurring on the agent when attempting to contact the management server on port
8250. Getting an ERROR logged, unable to initialize the threads, with an IOException -1 connection
closed with -1 on reading size.

This sounds suspiciously like an SSL client is attempting to connect to a non-SSL server.
For the life of me, I cannot see how this is configured or misconfigured.

I have created SSL certificates for the proxies, and successfully uploaded these, following
the documentation. Not sure this is related in any way or not.

Have turned on full debugging log output in log4j, not seeing any elaboration on the underlying
cause of the problem.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message