cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8864) Not able to add TCP port forwarding rule in VPN for specific ports
Date Sun, 27 Sep 2015 12:12:06 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8864?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14909707#comment-14909707
] 

ASF subversion and git services commented on CLOUDSTACK-8864:
-------------------------------------------------------------

Commit 3ded3e90007d08fa98465f2b8c68b7fb075557c0 in cloudstack's branch refs/heads/master from
[~remibergsma]
[ https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;h=3ded3e9 ]

Merge pull request #887 from schubergphilis/vr_fixes_combined

[BLOCKER] Combined PRs that fix VR issuesTonight I worked with @wilderrodrigues to figure
out what is wrong with the virtual router. As we couldn't test single PRs any more (because
of other issues with them causing tests to fail) we added all VR related PRs in a separate
branch and started testing from there.

We combined the following PRs into this PR:
#836 #851 #867 #870 #881 #882 #842

After that, one issue remains: the VPC does not get a default gateway. Which is strange, because
we already solved it in PR #738. When I look back, it was fixed again in PR #784. It could
very well be that either one fixed one specific case, but also breaking the other. We need
to investigate this, and make sure there will be a fix that works both for VPCs and VRs.

When we manually add the default gateway on the VPC, most tests pass and also spinning up
two VPCs with one tier each, having a VM and them using s2s to VPN them together works fine.
See for more details the report Wilder sent earlier.

Tomorrow we'll try to figure out how to fix the default gateway and merge this. Then we should
have a base to work from again. Any PR that fixes another blocker, should at least then be
rebased against the fixed master so we can run the tests against the PR branch. I'm not saying
everything is fixed, I'm just saying that we can spin up a cloud that has working VMs.

When, in the mean time, someone has the time to checkout this branch and make the default
route work for both VPC and VR that would be awesome. After that we should double check and
verify the test results.

Pinging @karuturi to let her know the current status.

Regards,
Wilder / Remi

* pr/887:
  Fixing the index out of bounds error in the check_if_link_up() function
  small cleanups
  Fixing the defaut route for VPC routers
  Formatting the get_gateway() method in the CsDatabag.py file
  Fixing the dhcpsrvr iptables file
  Formatting the router_proxy.sh script
  CLOUDSTACK-8881: Fixed Static and PF configuration issue
  CLOUDSTACK-8905: Fixed hooking egress rules
  CLOUDSTACK-8891: Fixed default iptables rules on VR  for guest traffic
  Configured dnsmasq to listen on all interfaces so that vpn  client gets dns
  CLOUDSTACK-8864: Not able to add TCP port forwarding rule in VPN for specific ports
  CLOUDSTACK-8863: VM doesn't reconnect to internet post VR RESTART/STOP-START/RECREATE
  CLOUDSTACK-8843: Fixed issue in default iptables rules on shared network VR

Signed-off-by: Remi Bergsma <github@remi.nl>


> Not able to add TCP port forwarding rule in VPN for specific ports
> ------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-8864
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8864
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.3.0
>            Reporter: sudharma jain
>
> Port forwading rule for ports 500,1701 and 4500 can't be added when a VPN is configured.
Trying to add a rule gives following error.
> "The range specified, xxxx, conflicts with rule xxxx which has 500-500."



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message