cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8792) Cannot live migrate VM with Libvirt prior to v1.0.1
Date Tue, 01 Sep 2015 22:04:46 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8792?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14726287#comment-14726287
] 

ASF GitHub Bot commented on CLOUDSTACK-8792:
--------------------------------------------

GitHub user mike-tutkowski opened a pull request:

    https://github.com/apache/cloudstack/pull/771

    Support live migration on older version of Libvirt

    https://issues.apache.org/jira/browse/CLOUDSTACK-8792
    
    A flag being passed to Libvirt assumes v1.0.0 or later.
    
    We need to put a check in the code to pass in a different flag if the version of Libvirt
is < 1.0.0.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/mike-tutkowski/cloudstack 4.5

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/cloudstack/pull/771.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #771
    
----
commit f5b51970488df6204508f7d2e6e8e7b03e865711
Author: Mike Tutkowski <mike.tutkowski@solidfire.com>
Date:   2015-09-01T22:00:08Z

    Support live migration on older version of Libvirt

----


> Cannot live migrate VM with Libvirt prior to v1.0.1
> ---------------------------------------------------
>
>                 Key: CLOUDSTACK-8792
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8792
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: KVM
>    Affects Versions: 4.6.0
>         Environment: Ubuntu 12.04 with Libvirt < v1.0.0
>            Reporter: Mike Tutkowski
>            Assignee: Mike Tutkowski
>             Fix For: 4.6.0
>
>
> A flag being passed to Libvirt assumes v1.0.0 or later.
> We need to put a check in the code to pass in a different flag if the version of Libvirt
is < 1.0.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message