cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (CLOUDSTACK-8750) Change the variable s_logger to non-static and fixed its name in “” and its subclasses
Date Thu, 17 Sep 2015 16:13:06 GMT


ASF GitHub Bot commented on CLOUDSTACK-8750:

Github user wilderrodrigues commented on the pull request:
    Hi there @rafaelweingartner,
    No hard feelings, dude. 
    Long story short:
    * we are going through a critical phase with ACS - release
    * I have been working on ACS since 2013, and it's always the same. We stable master, we
have a release and after that master is screwed again. After 6 months we go through this infinite
loop of mess and nightmares.
    * ACS is super uber tightly coupled, by the [bad] design it has. If I would tell you that
we had production problems because of 1 class of 1 hypervisor, that we don't even use, was
f*dup, you wouldn't believe me. So, any simple change has the potential to make a huge mess.
That's why the tests, etc.
    * I respect your efforts and also the guys working with you. I will be an student till
I die!
    If you can find a way to apply/submit your changes in an progressive way, I'm more than
glad to help.
    P.S.: adamantium claws, you know... I got to use them sometimes. ;)

> Change the variable s_logger to non-static and fixed its name in “”
and its subclasses
> --------------------------------------------------------------------------------------------------------------------------------------
>                 Key: CLOUDSTACK-8750
>                 URL:
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>            Reporter: pedro henrique pereira martins
>            Priority: Minor
>   Original Estimate: 48h
>  Remaining Estimate: 48h
> We have noticed that every single class that is a subclass of “ComponentLifecycleBase”
instantiate their on “logger” manually and uses a nonstandard name. We fixed that by changing
the variable in “ComponentLifecycleBase” to protected and non-static and instantiated
it using the method “getClass” from Object class. Therefore, we can reduce the code in
a few hundred lines and use a more intuitive name for the logger variable.
> We do understand that “s_ something“ is a proper way to instantiate a static variable
in ACS classes. However, in few of the subclasses of “”
it was used names such as “LOGGER” (that is a proper name for static field as JAVA standards),
log, status_logger and others.
> What we propose is to change the logger variable in “”
to protected and remove its static and final declaration. Therefore we did the following in
>    protected Logger logger = Logger.getLogger(getClass());
>   This way, every single subclass of ComponentLifecycleBase, when instantiated would
automatically have a logger instance for its proper class ready to be used.
> During that process we found a static method in class that used the “s_logger” variable
in classes:
> To fix that we proposed to create a new class 
> “”, instantiate it with @Componente and inject
into the aforementioned classes.
> That class will contain the following methods extracted from
>, String)
> However we don't know if all analyzed classes are singletons, if some of analyzed classes
aren't singletons. Therefore that change could have an impact on memory consumption. It will
require a deeper analysis to check which classes are singleton or not and leave the “logger”
as static in such classes.  
> We have a solution at our own branch 
> However, there is still the need to double-check the singleton problem.
> There is a PR we created in our first attempt to solve that problem:
> The dev that starts working on this ticket can reach us at any moment, hence that we
have mapped all of ComponentLifecycleBase subclasses that use the logger variable.

This message was sent by Atlassian JIRA

View raw message