cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8649) Register SSH keypair is broken
Date Tue, 18 Aug 2015 06:43:46 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8649?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14700810#comment-14700810
] 

ASF GitHub Bot commented on CLOUDSTACK-8649:
--------------------------------------------

Github user milamberspace commented on the pull request:

    https://github.com/apache/cloudstack/pull/615#issuecomment-132091017
  
    
    The PR #709 don't fix the issue for me. I can't add a SSH key pair without revert the
#615.


> Register SSH keypair is broken
> ------------------------------
>
>                 Key: CLOUDSTACK-8649
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8649
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.5.0, 4.5.1
>            Reporter: Lennert den Teuling
>
> It seems that when we upgraded form CS 4.3 to 4.5 the register SSH keypair functionality
broke. 
> Registering keypairs work, but deployments with these newly registered keypair fails
because they are not correctly put into the database. 
> It seems that at least half of the public key data is missing in the database. We have
tried this with multiple keys, even with keys that worked before. Keys that were registered
before the upgrade still work. 
> It is simple to reproduce, just register a SSH key and you will see the key will to be
correctly put into the "ssh_keypairs" table and encrypting the VM password with the key will
fail on deployment. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message