cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8649) Register SSH keypair is broken
Date Wed, 22 Jul 2015 21:07:04 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8649?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14637625#comment-14637625
] 

ASF GitHub Bot commented on CLOUDSTACK-8649:
--------------------------------------------

Github user wilderrodrigues commented on the pull request:

    https://github.com/apache/cloudstack/pull/615#issuecomment-123863689
  
    Hi Lennert,
    
    The Command claases use annotations for the fields. The fields values are set via reflection.
I bet my iPhone the decoding is being done there :)
    
    I will have a look tomorrow, as I might know where the whole thing is happening.
    
    For now I would say LGTM and please merge it.
    
    Cheers,
    Wilder
    
    Sent from my iPhone
    
    On 22 Jul 2015, at 20:29, Lennert den Teuling <notifications@github.com<mailto:notifications@github.com>>
wrote:
    
    
    @wilderrodrigues<https://github.com/wilderrodrigues> reproducing is really easy,
just try to register your public key using the registerSSHKeyPair API call. In the database
you will find you key, but only a part of it. You can try this on 4.5 but as far we know the
master contains this same issue. We did not test 4.4.
    
    @borisroman<https://github.com/borisroman> has been looking where the key gets decoded
first, but wasn't able to yet. If you can help, that would be great.
    
    —
    Reply to this email directly or view it on GitHub<https://github.com/apache/cloudstack/pull/615#issuecomment-123818145>.



> Register SSH keypair is broken
> ------------------------------
>
>                 Key: CLOUDSTACK-8649
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8649
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.5.0, 4.5.1
>            Reporter: Lennert den Teuling
>
> It seems that when we upgraded form CS 4.3 to 4.5 the register SSH keypair functionality
broke. 
> Registering keypairs work, but deployments with these newly registered keypair fails
because they are not correctly put into the database. 
> It seems that at least half of the public key data is missing in the database. We have
tried this with multiple keys, even with keys that worked before. Keys that were registered
before the upgrade still work. 
> It is simple to reproduce, just register a SSH key and you will see the key will to be
correctly put into the "ssh_keypairs" table and encrypting the VM password with the key will
fail on deployment. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message