cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8649) Register SSH keypair is broken
Date Wed, 22 Jul 2015 09:49:04 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8649?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14636611#comment-14636611
] 

ASF GitHub Bot commented on CLOUDSTACK-8649:
--------------------------------------------

GitHub user borisroman opened a pull request:

    https://github.com/apache/cloudstack/pull/614

    CLOUDSTACK-8649: Fixed unnecessary double url decoding in registerSSHKeyPair.

    The method cmd.getPublicKey() already returns a decoded string. So when we try to decode
it again the plus "+" signs are being decoded to white spaces. In a next step the key is cut
at the spaces and only the first two parts are being saved in the DB.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/borisroman/cloudstack CLOUDSTACK-8649

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/cloudstack/pull/614.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #614
    
----
commit 12a3642df683539fddb3f6be4b223b03744696e2
Author: Boris Schrijver <boris@pcextreme.nl>
Date:   2015-07-22T09:39:19Z

    CLOUDSTACK-8649: Fixed unnecessary double url decoding in registerSSHKeyPair.

----


> Register SSH keypair is broken
> ------------------------------
>
>                 Key: CLOUDSTACK-8649
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8649
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.5.0, 4.5.1
>            Reporter: Lennert den Teuling
>
> It seems that when we upgraded form CS 4.3 to 4.5 the register SSH keypair functionality
broke. 
> Registering keypairs work, but deployments with these newly registered keypair fails
because they are not correctly put into the database. 
> It seems that at least half of the public key data is missing in the database. We have
tried this with multiple keys, even with keys that worked before. Keys that were registered
before the upgrade still work. 
> It is simple to reproduce, just register a SSH key and you will see the key will to be
correctly put into the "ssh_keypairs" table and encrypting the VM password with the key will
fail on deployment. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message