cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wido den Hollander (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-8640) Uploads to S3 Secondary Storage fail, stay at 0% completed
Date Fri, 17 Jul 2015 08:17:05 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-8640?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Wido den Hollander updated CLOUDSTACK-8640:
-------------------------------------------
    Description: 
I noticed this after upgrading to 4.5.2 (build from 4.5 branch).

Uploads never completed when a template was downloaded en directly uploaded to S3 secondary
storage provided by Ceph's RADOS Gateway using Multipart.

After searching for hours I found this: http://docs.aws.amazon.com/AWSJavaSDK/latest/javadoc/com/amazonaws/event/ProgressEvent.html#getBytesTransferred()

The ProgressEvent of the returned that 0 bytes had been transferred. But when using the getBytes()
method it actually works.

The upload succeeds, but we check if the amount of uploaded bytes is equal or more then what
we expected. If not, we say the upload failed.

This happens inside S3TemplateDownloader (which really needs some fixes btw....)

Tracing this down if it's related to Ceph or actually something in S3TemplateDownloader.

I also tried the Amazon SDK 1.9.34, but that didn't make a difference.

  was:
I noticed this after upgrading to 4.5.2 (build from 4.5 branch).

Uploads never completed when a template was downloaded en directly uploaded to S3 secondary
storage provided by Ceph's RADOS Gateway using Multipart.

After searching for hours I found this: http://docs.aws.amazon.com/AWSJavaSDK/latest/javadoc/com/amazonaws/event/ProgressEvent.html#getBytesTransferred()

The ProgressEvent of the returned that 0 bytes had been transferred. But when using the getBytes()
method it actually works.

The upload succeeds, but we check if the amount of uploaded bytes is equal or more then what
we expected. If not, we say the upload failed.

This happens inside S3TemplateDownloader (which really needs some fixes btw....)

Tracing this down if it's related to Ceph or actually something in S3TemplateDownloader.

I also tried the Amazon SDK 1.9.34, but that didn't make a different.


> Uploads to S3 Secondary Storage fail, stay at 0% completed
> ----------------------------------------------------------
>
>                 Key: CLOUDSTACK-8640
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8640
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: SystemVM
>    Affects Versions: Future, 4.5.1
>         Environment: Ceph RADOS Gateway with Civetweb as Secondary Storage
>            Reporter: Wido den Hollander
>            Assignee: Wido den Hollander
>              Labels: amazon, ceph, rados, s3, secondary_storage
>
> I noticed this after upgrading to 4.5.2 (build from 4.5 branch).
> Uploads never completed when a template was downloaded en directly uploaded to S3 secondary
storage provided by Ceph's RADOS Gateway using Multipart.
> After searching for hours I found this: http://docs.aws.amazon.com/AWSJavaSDK/latest/javadoc/com/amazonaws/event/ProgressEvent.html#getBytesTransferred()
> The ProgressEvent of the returned that 0 bytes had been transferred. But when using the
getBytes() method it actually works.
> The upload succeeds, but we check if the amount of uploaded bytes is equal or more then
what we expected. If not, we say the upload failed.
> This happens inside S3TemplateDownloader (which really needs some fixes btw....)
> Tracing this down if it's related to Ceph or actually something in S3TemplateDownloader.
> I also tried the Amazon SDK 1.9.34, but that didn't make a difference.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message