cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daan Hoogland (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-5600) Xenserver - After HA , CPVM's disk is corrupted resulting in CPVM being stuck in "Starting" state.
Date Fri, 10 Jul 2015 15:05:12 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-5600?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daan Hoogland updated CLOUDSTACK-5600:
--------------------------------------
    Fix Version/s:     (was: 4.4.4)
                   Future

> Xenserver - After HA , CPVM's disk is corrupted resulting in CPVM being stuck in "Starting"
state.
> --------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5600
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5600
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.3.0
>         Environment: Build from 4.3
>            Reporter: Sangeetha Hariharan
>            Assignee: Alex Huang
>             Fix For: Future
>
>         Attachments: cpvmha.rar, hacpvm.png
>
>
> Xenserver - After HA , CPVM's disk is corrupted resulting in CPVM being stucK in "Starting"
state.
> Steps to reproduce the problem:
> Set up:
> Advanced zone with 2 xenserver 6.2 hosts.
> Steps to reproduce the problem:
> Deploy few HA enabled Vms in each of the hosts .
> Disconnect network connectivity on host1 ( ifconfig eth0 down).
> Host gets marked as down and all Vms gets HA-ed to the other host in the cluster - host2.
> CPVM got Ha-ed to host2 and worked fine.
> host1 get rebooted and is marked as "Up" state in CP.
> Now disconnect network connectivity on host2 ( ifconfig eth0 down).
> Host gets marked as down and all Vms gets HA-ed to the other host in the cluster - host1.
> After this HA process , I see that the CPVM is stuck in "Starting" state in CP , but
is in "Running" state in  Xenserver.
> When I log into the console of CPVM , we see the following exception suggesting a  disk
corruption:
> Duplicate or bad block in use!
> /dev/xvda5: Multiply-claimed block(s) in inode 224: 8455 8456
> /dev/xvda5: Multiply-claimed block(s) in inode 2026: 8455 8456
> /dev/xvda5: (There are 2 inodes containing multiply-claimed blocks.)
> /dev/xvda5: File /etc/inittab (inode #224, mod time Sat Dec 21 00:14:41 2013) 
>   has 2 multiply-claimed block(s), shared with 1 file(s):
> /dev/xvda5: /etc/iptables/rules.v4 (inode #2026, mod time Fri Dec 20 22:39:20 2013)
> /dev/xvda5: 
> /dev/xvda5: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
> (i.e., without -a or -p options)
> fsck died with exit status 4
> failed (code 4).
> An automatic file system check (fsck) of the root filesystem failed. A manual fsck must
be performed, then the system restarted. The fsck should be performed in maintenance mode
with the root filesystem mounted in read-only mode. ... failed!
> The root filesystem is currently mounted in read-only mode. A maintenance shell will
now be started. After performing system maintenance, press CONTROL-D to terminate the maintenance
shell and restart the system. ... (warning).
> Give root password for maintenance
> (or type Control-D to continue): 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message