cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrei Mikhailovsky (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-8201) KVM Snapshot to Template to New Instance is not working
Date Tue, 03 Feb 2015 20:39:35 GMT
Andrei Mikhailovsky created CLOUDSTACK-8201:
-----------------------------------------------

             Summary: KVM Snapshot to Template to New Instance is not working
                 Key: CLOUDSTACK-8201
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8201
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: KVM, Snapshot, Template
    Affects Versions: 4.4.2
         Environment: Ubuntu 14.04 LTS for management and host servers. Primary storage ceph
rbd, secondary storage nfs
            Reporter: Andrei Mikhailovsky
            Priority: Blocker


Unable to create an instance from a template which has been created from a volume snapshot.
To reproduce:

1. take a snapshot from the root volume of a working vm (i've used Windows 2008 R2 vm with
24GB root disk). 
2. Create a template from the snapshot
3. Create a new instance from the template
4. Try to boot

The new instance starts, however, the root disk volume is totally messed up. Instead of having
a 24GB root volume, just like in the original vm, I ended up with a 9.17GB root volume. The
partition table was correct though. The first partition (windows boot partition in my case)
was mountable. The second partition finished outside of the physical disk boundries and I
had all sorts of trouble mounting it. The OS obviously wouldn't boot.

Perhaps this relates to the CLOUDSTACK-8199 which i've created earlier?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message