cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daan Hoogland (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-8197) make minimal sysvm version configuratble
Date Tue, 03 Feb 2015 13:09:35 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-8197?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14303223#comment-14303223
] 

Daan Hoogland commented on CLOUDSTACK-8197:
-------------------------------------------

@Rohit I think what you propose would require upgrades on ACS upgrade even when not needed.
It should be possible to remain at a 4.4.2.123 version when upgrading to ACS 4.4.3 if the
fixes in it are unrelated to the sysvms. So a minimal version can be hard coded and on a custom
fix it can be edited to force 'requires update' on the routers (for a datacentre)

> make minimal sysvm version configuratble
> ----------------------------------------
>
>                 Key: CLOUDSTACK-8197
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-8197
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server, SystemVM
>            Reporter: Daan Hoogland
>            Assignee: Daan Hoogland
>
> MinVRVersion is hard coded in the VirtualNetworkApplianceService. To facilitate users
to make their own versions it must be a config key. As such it will be best to move it to
NetworkOrchestrationService as it's use is mostly from that layer.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message