cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Min Chen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-7884) Cloudstack MS is not responding (happening randomly) after some restart
Date Tue, 11 Nov 2014 17:28:34 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-7884?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14206648#comment-14206648
] 

Min Chen commented on CLOUDSTACK-7884:
--------------------------------------

Problem:
-------------------------
Management server is not responding intermittently after restart.

RCA:
-------------------------
The management server was not responding because it was not started fully and was not ready
to take any requests.

See the comments above for full analysis

Fix:
-----------------------
During Management server startup Lifecycle Handler Manager start all lifecycle handles one
by one sequentially in a random order based on RUN LEVELs of the Lifecycle Handler.

Id VirtualMachineManager Lifecycle Handler starts before AsyncJobManager lifecycle Handler
and if there are any pending jobs to be processed then the main thread will wait till it finishes
the scheduled job, but this job will never executed as asyncjob manager lifecycle handler
did not start.

Changed the RUN LEVEL of AsyncjobManager to make sure it gets initialised before Virtual manager
life cycle handler so that there is a queue to finish the scheduled job.

Notest to QA:
---------------------
Make sure there are some pending virtual machine jobs before restart of the management server
to test this.


> Cloudstack MS is not responding (happening randomly) after some restart
> -----------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-7884
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-7884
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.3.0
>            Reporter: Min Chen
>            Assignee: Min Chen
>            Priority: Critical
>             Fix For: 4.5.0
>
>
> some times after the restarting the MS ,not able to see the web UI login page (i.e not
getting the response from MS when we open http://<host>:8080/client Page) even though
MS is up and running.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message