cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-7532) [Templates] Template status is not shown in UI/API response for non-default account users
Date Wed, 15 Oct 2014 20:58:35 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-7532?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14172930#comment-14172930
] 

ASF subversion and git services commented on CLOUDSTACK-7532:
-------------------------------------------------------------

Commit 3b442acdd7977d09de60dfe61eaf6f148df1af4b in cloudstack's branch refs/heads/master from
[~nitinme]
[ https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;h=3b442ac ]

CLOUDSTACK-7532: Template status is not shown in UI/API response for non-default account users.
Show it if the owner of the template is the caller
(cherry picked from commit 42f628c61c4070f891b16c1a81d2985bcf8b9281)


> [Templates] Template status is not shown in UI/API response for non-default account users
> -----------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-7532
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-7532
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: API, Template
>    Affects Versions: 4.5.0
>         Environment: Latest build from master with commit:
> c33fea2cd27664db32c1173e98511470bf0a0724
>            Reporter: Sanjeev N
>            Assignee: Nitin Mehta
>            Priority: Critical
>              Labels: api, templates
>             Fix For: 4.5.0
>
>         Attachments: template_status.PNG
>
>
> [Templates] Template status is not shown in UI/API response for non-default account users
> Steps to Reproduce:
> ===============
> 1.Bring up CS with latest build
> 2.Create one account under root domain
> 3.Register template using the account created above
> 4.After the template download is completed verify the template status using the account
created at step2
> Expected Result:
> ==============
> In UI/API response status field should be there and it should be set to "Download Complete"
after the successful template download.
> Actual Behavior:
> ============
> Status is shown only for the default admin user. But it is not showed to other account
users.
> Impact:
> ======
> Marvin tests which use template register would fail because of the status filed missing.
> Following is the code from base.py where the tests are failing:
>  elif 'Downloaded' in template.status:
>                     time.sleep(interval)
> becasue template.status is NoneType 
> API:
> ====
> http://10.147.40.10:8080/client/api?command=listTemplates&sessionkey=SgRK4kwpxxjg3Jx%2FwePLoS0aK3c%3D&templatefilter=self&id=550ad6ac-38d2-11e4-a56e-d4ae527ccfaa&_=1410351906876
> API Response:
> ===========
> <listtemplatesresponse cloud-stack-version="4.5.0-SNAPSHOT"><count>1</count><template><id>550ad6ac-38d2-11e4-a56e-d4ae527ccfaa</id><name>CentOS
5.6(64-bit) no GUI (XenServer)</name><displaytext>CentOS 5.6(64-bit) no GUI (XenServer)</displaytext><ispublic>true</ispublic><created>2014-09-10T15:59:38+0530</created><isready>true</isready><passwordenabled>false</passwordenabled><format>VHD</format><isfeatured>true</isfeatured><crossZones>true</crossZones><ostypeid>572126ea-38d2-11e4-a56e-d4ae527ccfaa</ostypeid><ostypename>CentOS
5.6 (64-bit)</ostypename><account>system</account><zoneid>680f7c3a-a9ee-4ed3-b594-981d56f8da4b</zoneid><zonename>z2</zonename><size>21474836480</size><templatetype>BUILTIN</templatetype><hypervisor>XenServer</hypervisor><domain>ROOT</domain><domainid>54e9d4e4-38d2-11e4-a56e-d4ae527ccfaa</domainid><isextractable>true</isextractable><checksum>905cec879afd9c9d22ecc8036131a180</checksum><sshkeyenabled>false</sshkeyenabled><isdynamicallyscalable>true</isdynamicallyscalable></template></listtemplatesresponse>
> In the above API response status field is missing.
> This bug is easily reproducible.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message