cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohit Yadav (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (CLOUDSTACK-7340) Instances unable to reach internet using SG provider and KVM
Date Mon, 15 Sep 2014 11:24:34 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-7340?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rohit Yadav closed CLOUDSTACK-7340.
-----------------------------------
    Resolution: Cannot Reproduce

Cannot reproduce now, works for me.

> Instances unable to reach internet using SG provider and KVM
> ------------------------------------------------------------
>
>                 Key: CLOUDSTACK-7340
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-7340
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.4.0, 4.5.0, 4.4.1
>            Reporter: Rohit Yadav
>            Assignee: Rohit Yadav
>            Priority: Blocker
>             Fix For: 4.4.1
>
>
> Deployed a basic zone with Security Group, used KVM and setup agent.
> Host: Ubuntu 14.04, Core i7, 
> The test hardware had two nics but used only eth0 and created two bridges cloud0 and
cloud1:
> auto eth0
> iface eth0 inet manual
> auto wlan0
> iface wlan0 inet manual
> # Public network
> auto cloudbr0
> iface cloudbr0 inet static
>     address 192.168.1.150
>     netmask 255.255.255.0
>     gateway 192.168.1.1
>     dns-nameservers 192.168.1.1 8.8.8.8
>     #post-up route add default gw 192.168.1.1 
>     bridge_ports eth0
>     bridge_fd 5
>     bridge_stp off
>     bridge_maxwait 1
> # Private network
> auto cloudbr1
> iface cloudbr1 inet manual
>     bridge_ports none
>     bridge_fd 5
>     bridge_stp off
>     bridge_maxwait 1
> The cloudstack-agent (4.4.1) was configured to use cloudbr0 for public, private and guest
network in its properties file. The default gateway was setup to 192.168.1.1 on cloudbr0 interface.
> - SSVM was able to reach internet.
> - CPVM was not
> Bridge output:
> $ brctl show
> bridge name     bridge id               STP enabled     interfaces
> cloud0          8000.fe00a9fe0190       no              vnet0
>                                                         vnet4
>                                                         vnet8
> cloudbr0                8000.00012e4fde1c       no              eth0
>                                                         vnet1
>                                                         vnet2
>                                                         vnet3
>                                                         vnet5
>                                                         vnet6
>                                                         vnet7
>                                                         vnet9
> cloudbr1                8000.000000000000       no
> lxcbr0          8000.000000000000       no
> virbr0          8000.000000000000       yes
> I'm suspecting something with traffic not going to right nic, not good at debugging network/bridge/kvm
stuff so I'll need someone to setup and try with 4.4 branch.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message