cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harikrishna Patnala (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-7351) [Automation] test_02_deploy_ha_vm_from_iso test case fails during VM deploy
Date Thu, 21 Aug 2014 07:10:32 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-7351?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14105114#comment-14105114
] 

Harikrishna Patnala commented on CLOUDSTACK-7351:
-------------------------------------------------

I saw the below commit which removes the hardcoded value (hypervisor=XenServer), we need to
pass the hypervisortype while deploying the VM.

commit 2109418469e7434bfc13fce0a20d5464d0b7862f
Author: Gaurav Aradhye <gaurav.aradhye@clogeny.com>
Date:   Tue Aug 5 14:04:19 2014 +0530

    Fixed Marvin Issue: Hypervisor value was hardcoded to XenServer while deploying VM if
not specified

> [Automation] test_02_deploy_ha_vm_from_iso test case fails during VM deploy 
> ----------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-7351
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-7351
>             Project: CloudStack
>          Issue Type: Test
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.5.0
>         Environment: KVM (RHEL 6.3)
>            Reporter: Rayees Namathponnan
>            Assignee: Girish Shilamkar
>            Priority: Critical
>             Fix For: 4.5.0
>
>         Attachments: CLOUDSTACK-7351.rar
>
>
> This issue observed while running the test case integration.component.test_stopped_vm.TestDeployHaEnabledVM.test_02_deploy_ha_vm_from_iso
> This test case deploying VM with below command 
> 2014-08-14 15:59:45,255 DEBUG [c.c.a.ApiServlet] (catalina-exec-10:ctx-4e4260d3) ===START===
 10.223.240.194 -- GET  account=test-TestVMAcc
> ountLimit-test_02_deploy_ha_vm_from_iso-AYL50Y&domainid=8b53537a-23f9-11e4-9ac6-1a6f7bb0d0a8&displayname=testserver&signature=4xBMTxK5iiaze
> Fgwm2GisNo1SvM%3D&zoneid=a99226f1-d924-4156-8157-90bec0fa6579&apiKey=uBqUNp_2XuCg6uwv_LMLO2W6drySk_RYAiVlcdSda1yBfLTiC2SAlFk2LX9HLLpPkAs0zo
> TzASxzSN0OSUnfoQ&startvm=True&templateid=5cc1e055-5f49-4f12-91da-d01bf7ee509c&command=deployVirtualMachine&response=json&diskofferingid=543
> e345e-645a-4bf9-bd4e-af1db46470e7&serviceofferingid=db22034a-1bdd-494f-9627-fb6fd4e16585
> This deployment failed with below error 
> 2014-08-14 15:59:45,353 DEBUG [o.a.c.e.o.NetworkOrchestrator] (catalina-exec-10:ctx-4e4260d3
ctx-b9541cb6 ctx-d0edfeec) Releasing lock for Acct[76597f29-a3e7-41a8-abc7-1cef552cf748-test-TestVMAccountLimit-test_02_deploy_ha_vm_from_iso-AYL50Y]
> 2014-08-14 15:59:45,388 INFO  [c.c.a.ApiServer] (catalina-exec-10:ctx-4e4260d3 ctx-b9541cb6
ctx-d0edfeec) hypervisor parameter is needed to deploy VM or the hypervisor parameter value
passed is invalid
> Is it required to pass hypervisor type ? 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message