cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kishan Kavala (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-7197) Upgrade 4.2 to 4.4 failed, because of 4.3 template is not installed
Date Fri, 08 Aug 2014 05:05:12 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-7197?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14090309#comment-14090309
] 

Kishan Kavala commented on CLOUDSTACK-7197:
-------------------------------------------

There is a patch pending from Daan for this : https://reviews.apache.org/r/24229/
System template upgrade code is being added in 4.4to4.4.1 upgrade. Once that is in, template
upgrade in 4.2.1 to 4.3 needs to be removed. I've already provided my comments on review board.

> Upgrade 4.2 to 4.4 failed, because of 4.3 template is not installed
> -------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-7197
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-7197
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>         Environment: 4.2 management server + kvm host, 4.5 KVM template is downloaded
through url before upgrade.
>            Reporter: edison su
>            Assignee: Kishan Kavala
>             Fix For: 4.5.0
>
>
> After upgraded to 4.5 management server, management server failed to start:
> 2014-07-28 14:55:23,608 DEBUG [c.c.u.d.Upgrade421to430] (main:null) Done upgrading RAM
for service offering of Secondary Storage VM to 512
> 2014-07-28 14:55:23,608 DEBUG [c.c.u.d.Upgrade421to430] (main:null) Updating System Vm
template IDs
> 2014-07-28 14:55:23,615 DEBUG [c.c.u.d.Upgrade421to430] (main:null) Updating LXC System
Vms
> 2014-07-28 14:55:23,616 WARN  [c.c.u.d.Upgrade421to430] (main:null) 4.3.0 LXC SystemVm
template not found. LXC hypervisor is not used, so not failing upgrade
> 2014-07-28 14:55:23,618 DEBUG [c.c.u.d.Upgrade421to430] (main:null) Updating KVM System
Vms
> 2014-07-28 14:55:23,621 ERROR [c.c.u.DatabaseUpgradeChecker] (main:null) Unable to upgrade
the database
> com.cloud.utils.exception.CloudRuntimeException: 4.3.0 KVM SystemVm template not found.
Cannot upgrade system Vms
> 	at com.cloud.upgrade.dao.Upgrade421to430.updateSystemVmTemplates(Upgrade421to430.java:298)
> 	at com.cloud.upgrade.dao.Upgrade421to430.performDataMigration(Upgrade421to430.java:73)
> 	at com.cloud.upgrade.DatabaseUpgradeChecker.upgrade(DatabaseUpgradeChecker.java:326)
> 	at com.cloud.upgrade.DatabaseUpgradeChecker.check(DatabaseUpgradeChecker.java:447)
> 	at org.apache.cloudstack.spring.lifecycle.CloudStackExtendedLifeCycle.checkIntegrity(CloudStackExtendedLifeCycle.java:65)
> 	at org.apache.cloudstack.spring.lifecycle.CloudStackExtendedLifeCycle.start(CloudStackExtendedLifeCycle.java:55)
> 	at org.springframework.context.support.DefaultLifecycleProcessor.doStart(DefaultLifecycleProcessor.java:167)
> 	at org.springframework.context.support.DefaultLifecycleProcessor.access$200(DefaultLifecycleProcessor.java:51)
> 	at org.springframework.context.support.DefaultLifecycleProcessor$LifecycleGroup.start(DefaultLifecycleProcessor.java:339)
> 	at org.springframework.context.support.DefaultLifecycleProcessor.startBeans(DefaultLifecycleProcessor.java:143)
> 	at org.springframework.context.support.DefaultLifecycleProcessor.onRefresh(DefaultLifecycleProcessor.java:108)
> 	at org.springframework.context.support.AbstractApplicationContext.finishRefresh(AbstractApplicationContext.java:945)
> 	at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:482)
> 	at org.apache.cloudstack.spring.module.model.impl.DefaultModuleDefinitionSet.loadContext(DefaultModuleDefinitionSet.java:145)
> 	at org.apache.cloudstack.spring.module.model.impl.DefaultModuleDefinitionSet$2.with(DefaultModuleDefinitionSet.java:122)
> 	at org.apache.cloudstack.spring.module.model.impl.DefaultModuleDefinitionSet.withModule(DefaultModuleDefinitionSet.java:245)
> 	at org.apache.cloudstack.spring.module.model.impl.DefaultModuleDefinitionSet.withModule(DefaultModuleDefinitionSet.java:250)
> 	at org.apache.cloudstack.spring.module.model.impl.DefaultModuleDefinitionSet.withModule(DefaultModuleDefinitionSet.java:233)
> 	at org.apache.cloudstack.spring.module.model.impl.DefaultModuleDefinitionSet.loadContexts(DefaultModuleDefinitionSet.java:117)
> 	at org.apache.cloudstack.spring.module.model.impl.DefaultModuleDefinitionSet.load(DefaultModuleDefinitionSet.java:79)
> 	at org.apache.cloudstack.spring.module.factory.ModuleBasedContextFactory.loadModules(ModuleBasedContextFactory.java:37)
> 	at org.apache.cloudstack.spring.module.factory.CloudStackSpringContext.init(CloudStackSpringContext.java:70)
> 	at org.apache.cloudstack.spring.module.factory.CloudStackSpringContext.<init>(CloudStackSpringContext.java:57)
> 	at org.apache.cloudstack.spring.module.factory.CloudStackSpringContext.<init>(CloudStackSpringContext.java:61)
> 	at org.apache.cloudstack.spring.module.web.CloudStackContextLoaderListener.contextInitialized(CloudStackContextLoaderListener.java:52)
> 	at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3972)
> 	at org.apache.catalina.core.StandardContext.start(StandardContext.java:4467)
> 	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
> 	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
> The commit: c0f60651b94828d52407b3a6b6c47c451dabb45f, seems cause the trouble, we need
to figure out how to upgrade from 4.2 to 4.5 directly without downloading 4.3 template, if
possible.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message