cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Murali Reddy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-6757) [OVS] Deleting networks does not unplug nics from dom0 on xenserver
Date Thu, 28 Aug 2014 07:08:57 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-6757?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14113456#comment-14113456
] 

Murali Reddy commented on CLOUDSTACK-6757:
------------------------------------------

Problem;
-----------
GRE tunnel networks are internal networks in XenServer. A XenServer network created on a XenServer,
is visible across the hosts in the clusters. Only on the first host on which a VM is launched
there is a bridge created automatically. When a VM is launched on a different host in the
cluster, but on the same network, VM start will fail with VM_REQUIRES_NETWORK exception as
bridge is not automatically created by the Xenserver. To overcome this issue, there is a hack
put into CloudStack, so that bridge is create for internal network that is backing GRE tunnel
network. A vif is created on to the network and plugged in to dom0 which will result in the
bridge getting created. This bug describes the scenario where the VIF's created on dom0 are
not getting deleted when a network is deleted.

Root Cause Analysis:
--------------------------
Root cause is using the dom0 vif connected to a GRE tunnel network as a forcing function to
create bridge on the host. this VID is never deleted even when a network object created on
XenServer is deleted.

Proposed Solution:
------------------------
Proposed solution is to get rid of the hack the use vif connected to dom0 as a forcing function
to create bridge. With the fix in CLOUDSTACK-6925, we no longer need dom0 vif.

QA steps:
-------------

CLOUDSTACK-6925: actually fixes the use dom0 VIF issue. With CLOUDSTACK-6925, there is no
longer any vif''s are connected to dom0. Please ensure when GRE tunnel network is created
there is no VIF that gets plugged into dom0.

> [OVS] Deleting networks does not unplug nics from dom0 on xenserver
> -------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-6757
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-6757
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server, Network Controller, XenServer
>    Affects Versions: 4.4.0
>         Environment: Latest build from 4.4 with commit e6961fd21bb6d793302c234d0f409f66dc498072
>            Reporter: Sanjeev N
>            Assignee: Murali Reddy
>            Priority: Critical
>              Labels: DEV_REVIEWED, ovs
>             Fix For: 4.4.0
>
>
> [OVS] Deleting networks does not unplug nics from dom0 on xenserver
> Steps to reproduce:
> ================
> 1.Bring up CS in advanced zone with xen cluster
> 2.Create physical network with GRE isolation
> 3.Create network offering with virtual networking and ovs as the service provider
> 4.Create couple of guest networks with above network offering
> 5.Deploy few vms in each network
> 6.Delete the guest networks
> Expected Result:
> ==============
> When CS creates tunnel networks it plugs a vif on dom0 for every tunnel tunnetwork. However
it does not unplug the vif from dom0 even-though the network is deleted.
> Observations:
> ===========
> We can see that bridge is getting deleted from the host bug the vif is not getting unplugged
from dom0.
> Attaching MS log file. Please look for bridge named "OVSTunnel989" in the log file.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message