cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashutosk Kelkar (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (CLOUDSTACK-7137) [Automation] Fix the script "test_escalations_securitygroups.py" - Unable to execute API command deletesecuritygroup due to invalid value.
Date Tue, 22 Jul 2014 05:06:40 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-7137?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ashutosk Kelkar reassigned CLOUDSTACK-7137:
-------------------------------------------

    Assignee: Ashutosk Kelkar

> [Automation] Fix the script "test_escalations_securitygroups.py" - Unable to execute
API command deletesecuritygroup due to invalid value.
> ------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-7137
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-7137
>             Project: CloudStack
>          Issue Type: Test
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Automation, Test
>    Affects Versions: 4.5.0
>            Reporter: Chandan Purushothama
>            Assignee: Ashutosk Kelkar
>            Priority: Critical
>             Fix For: 4.5.0
>
>
> ============
> Error Message:
> ============
> test_01_list_securitygroups_pagination (integration.component.test_escalations_securitygroups.TestSecurityGroups):
DEBUG: ========Sending GET Cmd : deleteSecurityGroup=======
> requests.packages.urllib3.connectionpool: INFO: Starting new HTTP connection (1): 10.220.135.73
> requests.packages.urllib3.connectionpool: DEBUG: "GET /client/api?apiKey=Ra1mlXzCZU0K1l4MKDWdRbQDU67PCQuRnKYv3hyc-Q8hSvCSFjB32UtifLbS6oYpMeKaf0BCuUidMw0LqZeCMA&response=json&command=deleteSecurityGroup&signature=JB2or4xVThMUY0Pob4shmnqTe5s%3D&id=66eeb3b4-3b3d-4037-8483-7ed1a1485893
HTTP/1.1" 431 370
> test_01_list_securitygroups_pagination (integration.component.test_escalations_securitygroups.TestSecurityGroups):
ERROR: Exception:['Traceback (most recent call last):\n', '  File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackConnection.py",
line 308, in __parseAndGetResponse\n    response_cls)\n', '  File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/jsonHelper.py",
line 150, in getResultObj\n    raise cloudstackException.CloudstackAPIException(respname,
errMsg)\n', 'CloudstackAPIException: Execute cmd: deletesecuritygroup failed, due to: errorCode:
431, errorText:Unable to execute API command deletesecuritygroup due to invalid value. Invalid
parameter id value=66eeb3b4-3b3d-4037-8483-7ed1a1485893 due to incorrect long value format,
or entity does not exist or due to incorrect parameter annotation for the field in api cmd
class.\n']
> Traceback (most recent call last):
>   File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackConnection.py",
line 308, in __parseAndGetResponse
>     response_cls)
>   File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/jsonHelper.py",
line 150, in getResultObj
>     raise cloudstackException.CloudstackAPIException(respname, errMsg)
> CloudstackAPIException: Execute cmd: deletesecuritygroup failed, due to: errorCode: 431,
errorText:Unable to execute API command deletesecuritygroup due to invalid value. Invalid
parameter id value=66eeb3b4-3b3d-4037-8483-7ed1a1485893 due to incorrect long value format,
or entity does not exist or due to incorrect parameter annotation for the field in api cmd
class.
> test_01_list_securitygroups_pagination (integration.component.test_escalations_securitygroups.TestSecurityGroups):
ERROR: marvinRequest : CmdName: <marvin.cloudstackAPI.deleteSecurityGroup.deleteSecurityGroupCmd
object at 0x276fa90> Exception: ['Traceback (most recent call last):\n', '  File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackConnection.py",
line 375, in marvinRequest\n    raise self.__lastError\n', 'CloudstackAPIException: Execute
cmd: deletesecuritygroup failed, due to: errorCode: 431, errorText:Unable to execute API command
deletesecuritygroup due to invalid value. Invalid parameter id value=66eeb3b4-3b3d-4037-8483-7ed1a1485893
due to incorrect long value format, or entity does not exist or due to incorrect parameter
annotation for the field in api cmd class.\n']
> Traceback (most recent call last):
>   File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackConnection.py",
line 375, in marvinRequest
>     raise self.__lastError
> CloudstackAPIException: Execute cmd: deletesecuritygroup failed, due to: errorCode: 431,
errorText:Unable to execute API command deletesecuritygroup due to invalid value. Invalid
parameter id value=66eeb3b4-3b3d-4037-8483-7ed1a1485893 due to incorrect long value format,
or entity does not exist or due to incorrect parameter annotation for the field in api cmd
class.
> test_01_list_securitygroups_pagination (integration.component.test_escalations_securitygroups.TestSecurityGroups):
CRITICAL: EXCEPTION: test_01_list_securitygroups_pagination: ['Traceback (most recent call
last):\n', '  File "/usr/lib/python2.7/unittest/case.py", line 361, in run\n    self.tearDown()\n',
'  File "/home/jenkins/workspace/xenrt-reg-basic-xs/cloudstack.git/test/integration/component/test_escalations_securitygroups.py",
line 94, in tearDown\n    cleanup_resources(self.apiClient, self.cleanup)\n', '  File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/lib/utils.py",
line 121, in cleanup_resources\n    obj.delete(api_client)\n', '  File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/lib/base.py",
line 3260, in delete\n    apiclient.deleteSecurityGroup(cmd)\n', '  File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackAPI/cloudstackAPIClient.py",
line 1739, in deleteSecurityGroup\n    response = self.connection.marvinRequest(command, response_type=response,
method=method)\n', '  File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackConnection.py",
line 380, in marvinRequest\n    raise e\n', 'CloudstackAPIException: Execute cmd: deletesecuritygroup
failed, due to: errorCode: 431, errorText:Unable to execute API command deletesecuritygroup
due to invalid value. Invalid parameter id value=66eeb3b4-3b3d-4037-8483-7ed1a1485893 due
to incorrect long value format, or entity does not exist or due to incorrect parameter annotation
for the field in api cmd class.\n']
> --------------------- >> end captured logging << ---------------------
> Stacktrace
>   File "/usr/lib/python2.7/unittest/case.py", line 361, in run
>     self.tearDown()
>   File "/home/jenkins/workspace/xenrt-reg-basic-xs/cloudstack.git/test/integration/component/test_escalations_securitygroups.py",
line 94, in tearDown
>     cleanup_resources(self.apiClient, self.cleanup)
>   File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/lib/utils.py",
line 121, in cleanup_resources
>     obj.delete(api_client)
>   File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/lib/base.py",
line 3260, in delete
>     apiclient.deleteSecurityGroup(cmd)
>   File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackAPI/cloudstackAPIClient.py",
line 1739, in deleteSecurityGroup
>     response = self.connection.marvinRequest(command, response_type=response, method=method)
>   File "/local/jenkins/workspace/xenrt-reg-basic-xs/work.64/env/local/lib/python2.7/site-packages/marvin/cloudstackConnection.py",
line 380, in marvinRequest
>     raise e
> 'Execute cmd: deletesecuritygroup failed, due to: errorCode: 431, errorText:Unable to
execute API command deletesecuritygroup due to invalid value. Invalid parameter id value=66eeb3b4-3b3d-4037-8483-7ed1a1485893
due to incorrect long value format, or entity does not exist or due to incorrect parameter
annotation for the field in api cmd class.\n-------------------- >> begin captured stdout
<< ---------------------\n=== TestName: test_01_list_securitygroups_pagination | Status
: EXCEPTION ===\n\n\n--------------------- >> end captured stdout << ----------------------\n--------------------
>> begin captured logging << --------------------\nCSLog: DEBUG: Payload:



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message