cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Namita Chaudhari (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-4819) Created template within a project not shows up.
Date Tue, 15 Jul 2014 12:33:04 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-4819?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14062002#comment-14062002
] 

Namita Chaudhari commented on CLOUDSTACK-4819:
----------------------------------------------

So the issue basically is while listing templates or Iso a parameter "projectid" is passed
and based on that a list of permittedaccounts is obtanined whose ISOs or templates should
be listed. But during the ListIsoCmd / ListtemplateCmd, it is observed that the parameter
"projectId" has null value as it is not obtained from UI and hence the templates and isos
are not listed in project's template list.

I have verified that when value is passed for param "projectId", the api works fine and gives
the expected result due to which the templates/iso under projects are listed. Hence this is
an UI issue.

> Created template within a project not shows up.
> -----------------------------------------------
>
>                 Key: CLOUDSTACK-4819
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-4819
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.2.0
>         Environment: CS 4.2 KVM Hypervisor
>            Reporter: Andi Daniawan
>
> The template I've created in a project did not appear both in project's template lists
and default view template list. I've checked in the vm_template table on account_id column,
it refers to Acct-Test account.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message