cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sanjeev N (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-6828) [OVS] Tunnel ports are not getting deleted even failure in vm deployment
Date Tue, 03 Jun 2014 07:19:01 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-6828?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sanjeev N updated CLOUDSTACK-6828:
----------------------------------

    Attachment: ovstunnel-host14.log
                ovstunnel-host13.log
                management-server.rar

> [OVS] Tunnel ports are not getting deleted even failure in vm deployment
> ------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-6828
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-6828
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server, Network Controller
>    Affects Versions: 4.4.0
>         Environment: Latest build from 4.4 with commit 32bbc84db99d0e5f7f9b2a3fb41e4e783a2de350
>            Reporter: Sanjeev N
>            Assignee: Murali Reddy
>            Priority: Critical
>              Labels: ovs
>             Fix For: 4.4.0
>
>         Attachments: management-server.rar, ovstunnel-host13.log, ovstunnel-host14.log
>
>
> [OVS] Tunnel ports are not getting deleted even failure in vm deployment
> Steps to Reproduce:
> ================
> 1.Bringup CS in advanced zone with Xen cluster
> 2.Create physical network with GRE isolation
> 3.Create network offering with virtual networking and ovs as the connectivity service
provider.
> 4.Deploy vm with above offering and simulate vm failure
> (In my case I was trying with multiple physical networks scenario and because of some
configuration issues network implement failed so failure in vm deployment)
> Result:
> =====
> During vm deployment ovs bridge and tunnel ports were created between the two hosts.
But after the failure there was no clean up of the ovs-bridge and the tunnel ports.
> Observations:
> ==========
> xapi7 and xapi6 were the bridges created for the network.
> Following is the log snippet from ovstunnel log from both the hosts:
> [root@Rack1Pod1Host14 ~]# ovs-vsctl list-ports xapi7
> t10016-4-1
> [root@Rack1Pod1Host14 ~]# grep xapi7 /var/log/cloud/ovstunnel.log
> 2014-06-03 05:38:46    DEBUG [root] About to manually create the bridge:xapi7
> 2014-06-03 05:38:46    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', '--', '--may-exist',
'add-br', 'xapi7', '--', 'set', 'bridge', 'xapi7', 'other_config:gre_key=OVSTunnel10016']
> 2014-06-03 05:38:46    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'set', 'Bridge',
'xapi7', 'external_ids:xs-network-uuid=127de5bb-a423-2774-98b6-ce1827d261d7']
> 2014-06-03 05:38:46    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'set', 'Bridge',
'xapi7', 'stp_enable=true']
> 2014-06-03 05:38:46    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'get', 'bridge',
'xapi7', 'other_config:gre_key']
> 2014-06-03 05:38:46    DEBUG [root] Executing:['/opt/xensource/bin/xe', 'network-list',
'bridge=xapi7', '--minimal']
> 2014-06-03 05:38:46    DEBUG [root] Setup_ovs_bridge completed with result:SUCCESS:xapi7
> 2014-06-03 05:38:50    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', '--timeout=30',
'wait-until', 'bridge', 'xapi7', '--', 'get', 'bridge', 'xapi7', 'name']
> 2014-06-03 05:38:50    DEBUG [root] bridge xapi7 for creating tunnel - VERIFIED
> 2014-06-03 05:38:50    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'add-port', 'xapi7',
't10016-4-1', '--', 'set', 'interface', 't10016-4-1', 'type=gre', 'options:key=10016', 'options:remote_ip=10.147.42.13']
> 2014-06-03 05:38:50    DEBUG [root] Executing:['/opt/xensource/bin/xe', 'network-list',
'bridge=xapi7', '--minimal']
> 2014-06-03 05:38:50    DEBUG [root] Executing:['/usr/bin/ovs-ofctl', 'add-flow', 'xapi7',
'hard_timeout=0,idle_timeout=0,priority=1000,in_port=1,dl_dst=ff:ff:ff:ff:ff:ff,actions=drop']
> 2014-06-03 05:38:50    DEBUG [root] Executing:['/usr/bin/ovs-ofctl', 'add-flow', 'xapi7',
'hard_timeout=0,idle_timeout=0,priority=1000,in_port=1,ip,nw_dst=224.0.0.0/24,actions=drop']
> [root@Rack1Pod1Host13 ~]# ovs-vsctl list-ports xapi6
> t10016-1-4
> [root@Rack1Pod1Host13 ~]# grep xapi6 /var/log/cloud/ovstunnel.log
> 2014-06-03 05:38:56    DEBUG [root] About to manually create the bridge:xapi6
> 2014-06-03 05:38:56    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', '--', '--may-exist',
'add-br', 'xapi6', '--', 'set', 'bridge', 'xapi6', 'other_config:gre_key=OVSTunnel10016']
> 2014-06-03 05:38:56    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'set', 'Bridge',
'xapi6', 'external_ids:xs-network-uuid=ae6fe450-3399-7dad-b972-aa45755c2803']
> 2014-06-03 05:38:56    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'set', 'Bridge',
'xapi6', 'stp_enable=true']
> 2014-06-03 05:38:56    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'get', 'bridge',
'xapi6', 'other_config:gre_key']
> 2014-06-03 05:38:56    DEBUG [root] Executing:['/opt/xensource/bin/xe', 'network-list',
'bridge=xapi6', '--minimal']
> 2014-06-03 05:38:56    DEBUG [root] Setup_ovs_bridge completed with result:SUCCESS:xapi6
> 2014-06-03 05:38:56    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', '--timeout=30',
'wait-until', 'bridge', 'xapi6', '--', 'get', 'bridge', 'xapi6', 'name']
> 2014-06-03 05:38:56    DEBUG [root] bridge xapi6 for creating tunnel - VERIFIED
> 2014-06-03 05:38:56    DEBUG [root] Executing:['/usr/bin/ovs-vsctl', 'add-port', 'xapi6',
't10016-1-4', '--', 'set', 'interface', 't10016-1-4', 'type=gre', 'options:key=10016', 'options:remote_ip=10.147.42.14']
> 2014-06-03 05:38:57    DEBUG [root] Executing:['/opt/xensource/bin/xe', 'network-list',
'bridge=xapi6', '--minimal']
> 2014-06-03 05:38:57    DEBUG [root] Executing:['/usr/bin/ovs-ofctl', 'add-flow', 'xapi6',
'hard_timeout=0,idle_timeout=0,priority=1000,in_port=1,dl_dst=ff:ff:ff:ff:ff:ff,actions=drop']
> 2014-06-03 05:38:57    DEBUG [root] Executing:['/usr/bin/ovs-ofctl', 'add-flow', 'xapi6',
'hard_timeout=0,idle_timeout=0,priority=1000,in_port=1,ip,nw_dst=224.0.0.0/24,actions=drop']
> Please refer to job-99 for vm deployment in the attached MS log file.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message