cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Fisher (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-6554) [VMWARE]Guest VMs failed to access public network when VR's public IP and management IP are in same CIDR
Date Tue, 03 Jun 2014 01:30:02 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-6554?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ian Fisher updated CLOUDSTACK-6554:
-----------------------------------

    Fix Version/s: Future

> [VMWARE]Guest VMs failed to access public network when VR's public IP and management
IP are in same CIDR
> --------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-6554
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-6554
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Virtual Router, VMware
>    Affects Versions: 4.2.1
>         Environment: advanced zone, default network offering, public IPs in single CIDR,
management IPs in the same CIDR
>            Reporter: Ian Fisher
>             Fix For: Future
>
>
> When using same CIDR for public network and management network, guest VMs failed to connect
to computers in public network via VR with default network offering in VMware advanced zone.
It seems that the routing rules in custom routing table of VR caused this issue. Logged in
to VR and executed:
> ip route ls table Table_eth2
> and got:
> default via 10.4.12.1 dev eth1  proto static
> According to the rules in iptables and IP configuration of NICs, the device of this routing
rule seems should be eth2, which is for public network connection.
> The corresponding configuration script in ipassoc.sh is 
> sudo ip route add default via $defaultGwIP table $tableName proto static
> Rebooted the VR after Inserting "dev $ethDev" after "$defaultGwIP" and it seems to work.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message