cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mandar Barve (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-5583) vmopsSnapshot plug-in (XenServer) does not return an error when it should
Date Fri, 14 Mar 2014 06:26:46 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-5583?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13934682#comment-13934682
] 

Mandar Barve commented on CLOUDSTACK-5583:
------------------------------------------

I tried to reproduce the issue the way you mentioned with few changes. I don't have iSCSI
SAN on my setup. I connected a 2 GB disk that I presented as storage tagged NFS primary to
CS. I created a 1GB disk offering and then deployed a VM on this new primary. Took a couple
of snapshots like you mentioned and when tried to revert to one of them I did see an error
in vmops log that said revert_memory_snapshot returned NULL. Exception was thrown with async
job status result code 530 and text response as "Failed to revert VM snapshot". I think this
exception came later the vmops snapshot plugin code itself may not have landed into exception
handling path. I need to double check this.

Is this what you are referring to? Could you attach snippets of SMlog and mops.log when the
failure happened to the JIRA?

Thanks,
Mandar

> vmopsSnapshot plug-in (XenServer) does not return an error when it should
> -------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5583
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5583
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Xen
>    Affects Versions: 4.3.0
>         Environment: XenServer 6.1
>            Reporter: Mike Tutkowski
>             Fix For: 4.3.0
>
>
> I tried to revert a VM snapshot and one of my storage repositories had an insufficient
amount of space. The plug-in did not return an error message (it returned "0").
> From the XenServer vmopsSnapshot plug-in's revert_memory_snapshot method:
> [root@XenServer-6 ~]# xe snapshot-revert snapshot-uuid=82e33f6d-59f3-a26d-4171-d51cd58716d8
> Error code: SR_BACKEND_FAILURE_44
> Error parameters: , There is insufficient space, 
> An error should be returned from the plug-in instead of "0".



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message