cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "prashant kumar mishra (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-6065) No HA for shutdown VM
Date Mon, 10 Feb 2014 15:04:21 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-6065?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13896636#comment-13896636
] 

prashant kumar mishra commented on CLOUDSTACK-6065:
---------------------------------------------------

i tried same scenario  , UI shows vm is in stop state , but CS did not tried to start it on
other host


logs:
===
2014-02-10 14:01:59,372 INFO  [c.c.v.VirtualMachineManagerImpl] (AgentManager-Handler-6:null)
VM i-2-3-VM is sync-ed to at Stopped state according to power-off report from hypervisor
2014-02-10 14:01:59,383 DEBUG [c.c.a.m.AgentManagerImpl] (AgentManager-Handler-6:null) SeqA
4-10: Sending Seq 4-10:  { Ans: , MgmtId: 7145449848920, via: 4, Ver: v1, Flags: 100010, [{"com.cloud.agent.api.PingAnswer":{"_command":{"newGroupStates":{},"newStates":{"i-2-3-VM":"Stopped"},"_hostVmStateReport":{"i-2-3-VM":{"state":"PowerOff","host":"Rack1Pod1Host7"}},"_gatewayAccessible":true,"_vnetAccessible":true,"hostType":"Routing","hostId":4,"wait":0},"result":true,"wait":0}}]
}


> No HA for shutdown VM
> ---------------------
>
>                 Key: CLOUDSTACK-6065
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-6065
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server, UI
>    Affects Versions: 4.3.0
>         Environment: CentOS 6.5 Mgmt & HVs, KVM
>            Reporter: Nux
>              Labels: ha, kvm
>
> I create a service offering with HA, launch a VM with it. 
> I stop the VM from its console or SSH by issuing `poweroff` and the VM is not started
back on.
> This is what I see in the management log:
> http://fpaste.org/75667/67633139/raw/
> The UI keeps showing this VM as Running.
> However, if I force a reboot of its hypervisor ACS does do the right thing and starts
the VM on another HV.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message