cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Likitha Shetty (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-6007) [VMware] RestoreVM API fails with NPE
Date Mon, 03 Feb 2014 07:12:09 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-6007?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Likitha Shetty resolved CLOUDSTACK-6007.
----------------------------------------

    Resolution: Fixed

> [VMware] RestoreVM API fails with NPE
> -------------------------------------
>
>                 Key: CLOUDSTACK-6007
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-6007
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: VMware
>    Affects Versions: 4.2.0
>            Reporter: Likitha Shetty
>            Assignee: Likitha Shetty
>             Fix For: 4.3.0
>
>
> Steps to reproduce
> ------------------------
> 1. Deploy s VM with parameter startVM=false
> 2. Call restoreVirtualMachine api on the VM.
> The command will fail with an NPE.
> If a VM instance is deployed with startVm=false, then calling restoreVm on the instance
fails with NPE because in case of VMware CS tries to expunge the old root volume that has
not yet been created in primary store.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message