cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ana Paula de Sousa (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-5985) Unable to add a kvm host in UI
Date Mon, 03 Feb 2014 20:21:07 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-5985?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13889868#comment-13889868
] 

Ana Paula de Sousa commented on CLOUDSTACK-5985:
------------------------------------------------

It worked!
After I changed the INFO to DEBUG, as you said, I finally found the problem. 
The file /etc/cloud/agent/agent.properties had:
"private.network.device=cloudbr0
public.network.device=cloudbr0
guest.network.device=cloudbr0"
the problem was that my bridge wasn't cloudbr0, but br0. I changed to br0.
Then, I also realized that I was adding the host with the ip of my hyperviser, not with the
ip of management server.

Thanks a lot, it was really helpful.

> Unable to add a kvm host in UI
> ------------------------------
>
>                 Key: CLOUDSTACK-5985
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5985
>             Project: CloudStack
>          Issue Type: Test
>      Security Level: Public(Anyone can view this level - this is the default.) 
>         Environment: A physical machine acting as the hypervisor and a VM acting as the
management server. Both with Ubuntu OS 12.04.
>            Reporter: Ana Paula de Sousa
>              Labels: agent, host, management, networkbridge
>
> I'm trying to make tests with the cloudstack, but when I try to adding the host on the
web interface it gives me "unable to add the host".
> The log of the management-server.log gives me:
> 2014-01-29 20:12:25,196 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null)
Skip capacity scan due to there is no Primary Storage$
> 2014-01-29 20:12:26,221 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 0 routers to update status.
> 2014-01-29 20:12:26,222 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 0 networks to update RvR status.
> 2014-01-29 20:12:55,196 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null)
Skip capacity scan due to there is no Primary Storage$
> 2014-01-29 20:12:56,221 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 0 routers to update status.
> 2014-01-29 20:12:56,222 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 0 networks to update RvR status.
> 2014-01-29 20:13:01,259 DEBUG [host.dao.HostDaoImpl] (ClusteredAgentManager Timer:null)
Resetting hosts suitable for reconnect
> 2014-01-29 20:13:01,260 DEBUG [host.dao.HostDaoImpl] (ClusteredAgentManager Timer:null)
Completed resetting hosts suitable for reconnect
> 2014-01-29 20:13:01,260 DEBUG [host.dao.HostDaoImpl] (ClusteredAgentManager Timer:null)
Acquiring hosts for clusters already owned by this management $
> 2014-01-29 20:13:01,261 DEBUG [host.dao.HostDaoImpl] (ClusteredAgentManager Timer:null)
Completed acquiring hosts for clusters already owned by this m$
> 2014-01-29 20:13:01,261 DEBUG [host.dao.HostDaoImpl] (ClusteredAgentManager Timer:null)
Acquiring hosts for clusters not owned by any management server
> 2014-01-29 20:13:01,262 DEBUG [host.dao.HostDaoImpl] (ClusteredAgentManager Timer:null)
Completed acquiring hosts for clusters not owned by any manage$
> 2014-01-29 20:13:11,379 DEBUG [cloud.server.StatsCollector] (StatsCollector-2:null) VmStatsCollector
is running...
> 2014-01-29 20:13:11,379 DEBUG [cloud.server.StatsCollector] (StatsCollector-1:null) HostStatsCollector
is running...
> 2014-01-29 20:13:11,385 DEBUG [cloud.server.StatsCollector] (StatsCollector-2:null) StorageCollector
is running...
> 2014-01-29 20:13:25,196 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null)
Skip capacity scan due to there is no Primary Storage$
> 2014-01-29 20:13:26,221 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 0 routers to update status.
> 2014-01-29 20:13:26,221 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 0 networks to update RvR status.
> The agent.log gives me:
> 2014-01-29 19:43:50,887 INFO  [cloud.agent.AgentShell] (main:null) Agent started
> 2014-01-29 19:43:50,888 INFO  [cloud.agent.AgentShell] (main:null) Implementation Version
is 4.2.0
> 2014-01-29 19:43:50,889 INFO  [cloud.agent.AgentShell] (main:null) agent.properties found
at /etc/cloudstack/agent/agent.properties
> 2014-01-29 19:43:50,890 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to using
properties file for storage
> 2014-01-29 19:43:50,890 INFO  [cloud.agent.AgentShell] (main:null) Defaulting to the
constant time backoff algorithm
> 2014-01-29 19:43:50,893 INFO  [cloud.utils.LogUtils] (main:null) log4j configuration
found at /etc/cloudstack/agent/log4j-cloud.xml
> 2014-01-29 19:43:50,959 INFO  [cloud.agent.Agent] (main:null) id is
> 2014-01-29 19:43:50,961 WARN  [cloud.resource.ServerResourceBase] (main:null) Nics are
not specified in properties file/db, will try to autodiscover
> 2014-01-29 19:43:50,964 INFO  [cloud.resource.ServerResourceBase] (main:null) Designating
private to be nic br0
> 2014-01-29 19:43:50,971 INFO  [resource.virtualnetwork.VirtualRoutingResource] (main:null)
VirtualRoutingResource _scriptDir to use: scripts/network/d$
> 2014-01-29 19:43:51,342 ERROR [cloud.agent.AgentShell] (main:null) Unable to start agent:
Failed to get private nic name
> I already have a bridge on my hypervisor which makes the management server recognize
the hypervisor.
> I have a feeling that the problem is on the configuration of the network environment,
but I can't find where it is.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message