cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jessica Wang (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-5098) [UI] Zone view is showing "Add VMware Datacenter" button even though zone is already associated with a data center
Date Wed, 05 Feb 2014 23:02:10 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-5098?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jessica Wang resolved CLOUDSTACK-5098.
--------------------------------------

    Resolution: Fixed

commit 299b05691228a6be2d6c912a12ab46886e892f05
Author: Jessica Wang <jessicawang@apache.org>
Date:   Wed Feb 5 14:59:02 2014 -0800

    CLOUDSTACK-5098: UI > VMware > during zone creation, after addVmwareDc succeeds,
if addClsuter fails (e.g. because of wrong input value), zone detail page will show wrong
button ("Add Vmware Datacenter") since listVmwareDcs is only c
    To resolve this specific use case, change UI to use listApis instead of listClusters to
determine whether to call listVmwareDcs.

branch: 4.2.1


> [UI] Zone view is showing "Add VMware Datacenter" button even though zone is already
associated with a data center
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5098
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5098
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: UI
>    Affects Versions: 4.2.1
>            Reporter: Sailaja Mada
>            Assignee: Jessica Wang
>            Priority: Critical
>             Fix For: 4.3.0
>
>         Attachments: UI_changed_to_use_listClusters_instead_of_listApis_to_determine_whether_to_call_listVmwareDcs.PNG,
apilog.log, management-server.log
>
>
> Steps:
> 1. Enable Nexus flag at the global level
> 2. Tried to configure the Adv zone with VMWARE hypervisor with out specifying Nexus vSwitch
details while adding the cluster.  
> With this Cluster addition failed . So i have cancelled the zone configuration.
> Now  tried below steps:
> 1)  Removed Pod and then tried to remove zone . It failed saying "The zone is not deletable
because there are VMware datacenters associated with this zone. Remove VMware DC from this
zone."
> 2)  There is no Remove DC option , When i go to Zone details in the UI 
> Observation:  
> 1) Entries in vmware_data_center and vmware_data_center_zone_map are not cleaned up when
there is a failure to add the cluster
> 2) So with this issue when i try to add the cluster  , it is failing saying "This data
center is already part of other Cloudstack Zone"
> So when there is a failure to add cluster for any reason , we should remove the addDC
association in the DB aswell.
> I did delete the rows from vmware_data_center and vmware_data_center_zone_map , Then
i was able to reuse the Datacenter



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message