cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "edison su (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-5831) As regular user , when trying to take a snapshot , snapshot succeeds but user is presented with "The given command does not exist or it is not available for user" message.
Date Mon, 13 Jan 2014 18:34:59 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-5831?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13869805#comment-13869805
] 

edison su commented on CLOUDSTACK-5831:
---------------------------------------

Seems you are  not using latest 4.3 branch? I remembered I fixed this NPE last week. 

The line number in above log doesn’t match latest 4.3 branch:


> As regular user , when trying to take a snapshot , snapshot succeeds but user is presented
with "The given command does not exist or it is not available for user" message.
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5831
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5831
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: UI
>    Affects Versions: 4.3.0
>         Environment: Build from 4.3
>            Reporter: Sangeetha Hariharan
>            Assignee: Jessica Wang
>            Priority: Blocker
>             Fix For: 4.3.0
>
>         Attachments: snapshot.png, the_checkin_that_causes_error_TheGivinCommandDoesNotExistOrItIsNotAvailableForUser.PNG
>
>
> As regular user , when trying to take a snapshot , snapshot succeeds but user is presented
with "The given command does not exist or it is not available for user" message.
> As a regular user ,  deploy a VM.
> From storage list view , select ROOT volume and create a snapshot.
> On "Take Snapshot" notification pop up , click on "OK".
> Notice that you are presented withe following message:
> "The given command does not exist or it is not available for user" 
> Following api call was made by the UI:
> http://10.223.49.5:8080/client/api?command=listStoragePools&id=undefined&response=json&sessionkey=4vcnR7sxOFnZcx6pUcyfnj%2BrN3o%3D&_=1389134167406
> { "errorresponse" : {"uuidList":[],"errorcode":432,"cserrorcode":9999,"errortext":"The
given command does not exist or it is not available for user"} }
> This issue is not seen when testing as "Admin" user and happens only with regular users.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message