cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Animesh Chaturvedi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-5502) [Automation] createVlanIpRange API failing, if you pass VLAN
Date Thu, 09 Jan 2014 21:29:51 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-5502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13867090#comment-13867090
] 

Animesh Chaturvedi commented on CLOUDSTACK-5502:
------------------------------------------------

Daan we need to continue with older behavior as called out by Marcus, please review and respond
as this has been pending,

> [Automation] createVlanIpRange API failing, if you pass VLAN 
> -------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5502
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5502
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.3.0
>         Environment: KVM Basic Zone with SG
>            Reporter: Rayees Namathponnan
>            Assignee: Daan Hoogland
>            Priority: Blocker
>             Fix For: 4.3.0
>
>
> This issue found in KVM basic zone with SG automation run;  test cases from below suite
filed 
> integration.component.test_multiple_ip_ranges.
> Steps to reproduce 
> Step 1 :  Create basic zone with SG
> Step 2 : Crete IP VLAN Range with below command (pass vlan=untagged)
> http://xxx.xxxx.xxx.xxx:8096/?command=createVlanIpRange&gateway=10.223.251.1&forvirtualnetwork=false&startip=10.223.251.3&podid=0253bcbf-e636-4776-9e8c-216b70d195a2&zoneid=a9912aa8-a231-44d9-a70b-9d53e6db2d27&netmask=255.255.255.192&vlan=untagged
> Result;
> API command failed with error 
> { "createvlaniprangeresponse" : {"uuidList":[],"errorcode":431,"cserrorcode":4350,"errortext":"Vlan
doesn't match vlan of the network"} }
> this API command works only, if you are not passing any VLAN



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message