cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Santhosh Kumar Edukulla (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-5423) [Automation] : deployAndRun and TestCaseExecuteEngine needs modification
Date Tue, 10 Dec 2013 11:32:06 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-5423?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Santhosh Kumar Edukulla updated CLOUDSTACK-5423:
------------------------------------------------

    Description: 
1. As part of recent changes to marvin, mentioned files requires some changes. 
2. Some cleaning is as well required for these two files. Did clean up.
3. Did cleanup in deployAndRun and added proper flow for ease of understanding.
4. Removed unwanted logging and used MarvinInit for initialization of Marvin.
5. Removed few unwanted loops and redundant code.
6. Renamed  TestCaseExecuteEngine.py -> tcExecuteEngine.py inline with other naming convention
for modules in Marvin
7. Added few codes and doc strings.

  was:As part of recent changes to marvin, mentioned files requires some changes. Some cleaning
is as well required for these two files


> [Automation] : deployAndRun and TestCaseExecuteEngine needs modification
> ------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5423
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5423
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Automation, marvin
>            Reporter: Santhosh Kumar Edukulla
>            Assignee: Santhosh Kumar Edukulla
>
> 1. As part of recent changes to marvin, mentioned files requires some changes. 
> 2. Some cleaning is as well required for these two files. Did clean up.
> 3. Did cleanup in deployAndRun and added proper flow for ease of understanding.
> 4. Removed unwanted logging and used MarvinInit for initialization of Marvin.
> 5. Removed few unwanted loops and redundant code.
> 6. Renamed  TestCaseExecuteEngine.py -> tcExecuteEngine.py inline with other naming
convention for modules in Marvin
> 7. Added few codes and doc strings.



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message