cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jessica Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-5098) [UI] Zone view is showing "Add VMware Datacenter" button even though zone is already associated with a data center
Date Mon, 09 Dec 2013 23:56:08 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-5098?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13843722#comment-13843722
] 

Jessica Wang commented on CLOUDSTACK-5098:
------------------------------------------

Sateesh,

> Because when listClusters API response does not include any cluster that has VMware hypervisor,
UI will presume the zone does not use VMware, therefore, there is no reason to call listVmwareDcs
API.

UI has this criterion because listVmwareDcs API is only available in non-oss build, but not
oss-build.
And there is no way to tell whether management server is running in an oss build or non-oss
build.

If UI calls listVmwareDcs API in an oss build, an error “this API doesn’t exist” will
throw (which a lot of people complaint annoying and confusing).

That’s why I made zone detail page to check whether the zone has a VMware cluster first.

Jessica


> [UI] Zone view is showing "Add VMware Datacenter" button even though zone is already
associated with a data center
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5098
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5098
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: API
>    Affects Versions: 4.2.1
>            Reporter: Sailaja Mada
>            Assignee: Jessica Wang
>            Priority: Critical
>             Fix For: 4.3.0
>
>         Attachments: apilog.log, management-server.log
>
>
> Steps:
> 1. Enable Nexus flag at the global level
> 2. Tried to configure the Adv zone with VMWARE hypervisor with out specifying Nexus vSwitch
details while adding the cluster.  
> With this Cluster addition failed . So i have cancelled the zone configuration.
> Now  tried below steps:
> 1)  Removed Pod and then tried to remove zone . It failed saying "The zone is not deletable
because there are VMware datacenters associated with this zone. Remove VMware DC from this
zone."
> 2)  There is no Remove DC option , When i go to Zone details in the UI 
> Observation:  
> 1) Entries in vmware_data_center and vmware_data_center_zone_map are not cleaned up when
there is a failure to add the cluster
> 2) So with this issue when i try to add the cluster  , it is failing saying "This data
center is already part of other Cloudstack Zone"
> So when there is a failure to add cluster for any reason , we should remove the addDC
association in the DB aswell.
> I did delete the rows from vmware_data_center and vmware_data_center_zone_map , Then
i was able to reuse the Datacenter



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message