cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Damodar Reddy T (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-5226) CS never goes down when both M1 and M2 are down in case of DB HA enabled.
Date Tue, 26 Nov 2013 06:12:35 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-5226?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13832347#comment-13832347
] 

Damodar Reddy T commented on CLOUDSTACK-5226:
---------------------------------------------

Tested on 5.1.X version of mysql and not able to reproduce it. Kiran which version of mysql
have you tried?

> CS never goes down when both M1 and M2 are down in case of DB HA enabled.
> -------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-5226
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5226
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.3.0
>            Reporter: Kiran Koneti
>            Assignee: Damodar Reddy T
>            Priority: Critical
>             Fix For: 4.3.0
>
>
> 1)I have created a DB replication with two masters M1 and M2  
> 2)Have enabled the parameter db.ha.enabled=true and then made CS setup is up with the
db replication.
> 3)Made the M1 down initially and the M2 down.
> 4) CS tries to reconnect to the databases and never goes down.
> 5)Tried with the  db.ha.enabled=false and then made the M1 down.
> 6)The CS goes to shutdown immediately.
> Expected result is:
> CS should retry for the DB's to come up for some fixed time(say 10 mins) and then should
go down. May be we need to add a parameter defining the number of retries or number of secs
to wait for either of Db's to come up. 



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message