cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ihor Kravchuk (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-5088) Incorrect awsapi documentation (ec2 api version and link to cloudstack-aws-api-register)
Date Thu, 07 Nov 2013 20:57:17 GMT
Ihor Kravchuk created CLOUDSTACK-5088:
-----------------------------------------

             Summary: Incorrect awsapi documentation (ec2 api version and link to  cloudstack-aws-api-register)
                 Key: CLOUDSTACK-5088
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-5088
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: AWSAPI, Doc
    Affects Versions: 4.2.0
            Reporter: Ihor Kravchuk
            Priority: Minor


According to documentation Cloudstack 4.2. supports AWS API version 2010-11-15.
This not correct. Correct version is 2012-08-15.
Ec2-tools release http://aws.amazon.com/releasenotes/Amazon-EC2/8276736673394143

The same mistake in Boto Examples.

Link to  cloudstack-aws-api-register incorrect. 
Should be:
 get -O cloudstack-aws-api-register "https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=blob_plain;f=awsapi-setup/setup/cloudstack-aws-api-register;hb=4.2"

Both mistakes makes almost impossible to make awsapi working if you follow documentation:
1. User registration fails with error 400
2. ec2 tools return: unexpected subelement




--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message