cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koushik Das (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-4699) Xenserver 6.1 - When a host gets added to an existing cluster with hosts , Add host succeeds but is in "Alert" state. Transitions to "Connecting" and "Up" state after some time.
Date Wed, 18 Sep 2013 17:55:51 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-4699?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Koushik Das resolved CLOUDSTACK-4699.
-------------------------------------

    Resolution: Not A Problem

This is by design. For 1st host in a cluster it is owned by the MS from where the operation
is performed. For all subsequent hosts in the cluster the constraint is that it should be
owned by the same MS as the 1st host. Since the add host can be done on any MS, the API simply
discovers the host and on successful discovery creates an entry in the database. The actual
agent connect is handled by the direct agent scan task separately.
                
> Xenserver 6.1 - When a host gets added to an existing cluster with hosts , Add host succeeds
but is in "Alert" state. Transitions to "Connecting" and "Up" state after some time.
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-4699
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-4699
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.2.1
>         Environment: Tested with build from 4.2-forward
>            Reporter: Sangeetha Hariharan
>            Assignee: Koushik Das
>             Fix For: 4.2.1
>
>         Attachments: management-server.rar
>
>
> Xenserver 6.1 - When a host gets added to an existing cluster with hosts , Add host succeeds
but is in "Alert" state. Transitions to "Connecting" and "Up" state after some time.
> Set up:
> Advanced Zone with 1 cluster having 1 host - Xenserver 6.1.
> When I try to add second host to a cluster (which already has 1 host) , we see the host
addition succeeds. But we see the host in "Alert" state then transitioning to "Connecting"
state and after a while gets to "Up" state.
> apilog.log:2013-09-17 11:15:48,937 INFO [cloud.api.ApiServer] (catalina-exec-1:null)
(userId=2 accountId=2 sessionId=3973A205C2F1BCD4FC41F46D9BBCEB66) 10.215.3.9 – POST command=addHost&response=json&sessionkey=4Xt2OZIdOBK4kvtp%2BRWMau%2B%2Bj0I%3D
200 { "addhostresponse" : { "count":1 ,"host" : [
> {"id":"769e9041-3fc6-4a37-91af-93e7e2c2139d","name":"Rack2Host16.lab.vmops.com","state":"Alert","type":"Routing","ipaddress":"10.223.50.195","zoneid":"a465e027-8a96-42c1-87f4-f3bc2efd1dce","zonename":"zone2","podid":"0e7e9cb3-6fa8-4101-890d-4520fc34de6b","podname":"pod2","version":"4.2.0","hypervisor":"XenServer","cpunumber":4,"cpuspeed":2261,"cpuallocated":"0%","cpuwithoverprovisioning":"9044.0","memorytotal":16189931520,"memoryallocated":0,"capabilities":"xen-3.0-x86_64
, xen-3.0-x86_32p , hvm-3.0-x86_32 , hvm-3.0-x86_32p , hvm-3.0-x86_64","lastpinged":"1969-12-31T16:00:00-0800","clusterid":"914a29ce-9384-4715-b758-e1ee04bb7c3c","clustername":"cluster2","clustertype":"CloudManaged","islocalstorageactive":false,"created":"2013-09-17T11:15:48-0700","events":"ManagementServerDown;
Remove; AgentConnected; AgentDisconnected; Ping; ShutdownRequested","resourcestate":"Enabled","hypervisorversion":"6.1.0","hahost":false}
> ] } }
> Attaching management server logs

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message