cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sanjeev N (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-4372) [XenServer] Commands info which are executed via xenserver are not logged in SMlog
Date Fri, 16 Aug 2013 13:29:50 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-4372?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sanjeev N updated CLOUDSTACK-4372:
----------------------------------

    Attachment: management-server.rar
                xensource.log
                SMlog
                messages

Attached xensource.log,SMlog,messages files from xenserver and management server log
                
> [XenServer] Commands info which are executed via xenserver are not logged in SMlog
> ----------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-4372
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-4372
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server, XenServer
>    Affects Versions: 4.2.0
>         Environment: Latest build from ACS 4.2 branch
> XenServer: 6.2
>            Reporter: Sanjeev N
>            Priority: Critical
>             Fix For: 4.2.0
>
>         Attachments: management-server.rar, messages, SMlog, xensource.log
>
>
> Any command info wich CS executes via xenserver is supposed to be logged in SMlog.
> But in my setup after bringing up setup , initially messages for logged in SMlog but
after sometime I didn't see any updates in the SMlog. 
> Usually SMlog rotation happens quite frequently but this time I din't see any update
in SMlog after certain point of time.
> Whatever the commands CS executes via xenserver will be logged in SMlog but I don't see
them after some time. Looks like some issue with SMlog rotation.
> I tried to create snapshots on multiple data disks after immediately brining up my setup
with few guest vms.
> For first snapshot I could see the logging info in SMlog. But for the next snapshots
I dint see any info in SMlog.
> 2013-08-16 08:59:09,066 DEBUG [cloud.async.AsyncJobManagerImpl] (Job-Executor-20:job-20
= [ be35359a-ccc0-41d1-b1e0-ddbaa357d570 ]) Executing org.apache.cloudstack.api.command.user.snapshot.CreateSnapshotCmd
for job-20 = [ be35359a-ccc0-41d1-b1e0-ddbaa357d570 ]
> 2013-08-16 08:59:09,099 INFO  [user.snapshot.CreateSnapshotCmd] (Job-Executor-20:job-20
= [ be35359a-ccc0-41d1-b1e0-ddbaa357d570 ]) VOLSS: createSnapshotCmd starts:1376657949099
> 2013-08-16 08:59:09,149 DEBUG [agent.transport.Request] (Job-Executor-20:job-20 = [ be35359a-ccc0-41d1-b1e0-ddbaa357d570
]) Seq 1-2011234581: Sending  { Cmd , MgmtId: 6615759585382, via: 1, Ver: v1, Flags: 100011,
[{"org.apache.cloudstack.storage.command.CreateObjectCommand":{"data":{"org.apache.cloudstack.storage.to.SnapshotObjectTO":{"volume":{"uuid":"ed6dc51d-713b-400d-9006-8256b9cb9e82","volumeType":"DATADISK","dataStore":{"org.apache.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"c65a038a-750c-3b4f-bf26-7ce3b74e1c85","id":2,"poolType":"NetworkFilesystem","host":"10.147.28.7","path":"/export/home/sanjeev/pri_xen_os","port":2049}},"name":"test","size":5368709120,"path":"d700bb94-7489-4c80-9099-e8b484794c6e","volumeId":7,"vmName":"i-2-5-VM","accountId":2,"format":"VHD","id":7,"hypervisorType":"XenServer"},"dataStore":{"org.apache.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"c65a038a-750c-3b4f-bf26-7ce3b74e1c85","id":2,"poolType":"NetworkFilesystem","host":"10.147.28.7","path":"/export/home/sanjeev/pri_xen_os","port":2049}},"vmName":"i-2-5-VM","name":"vm2-xen_test_20130816125908","hypervisorType":"XenServer","id":4}},"wait":0}}]
}
> 2013-08-16 08:59:09,149 DEBUG [agent.transport.Request] (Job-Executor-20:job-20 = [ be35359a-ccc0-41d1-b1e0-ddbaa357d570
]) Seq 1-2011234581: Executing:  { Cmd , MgmtId: 6615759585382, via: 1, Ver: v1, Flags: 100011,
[{"org.apache.cloudstack.storage.command.CreateObjectCommand":{"data":{"org.apache.cloudstack.storage.to.SnapshotObjectTO":{"volume":{"uuid":"ed6dc51d-713b-400d-9006-8256b9cb9e82","volumeType":"DATADISK","dataStore":{"org.apache.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"c65a038a-750c-3b4f-bf26-7ce3b74e1c85","id":2,"poolType":"NetworkFilesystem","host":"10.147.28.7","path":"/export/home/sanjeev/pri_xen_os","port":2049}},"name":"test","size":5368709120,"path":"d700bb94-7489-4c80-9099-e8b484794c6e","volumeId":7,"vmName":"i-2-5-VM","accountId":2,"format":"VHD","id":7,"hypervisorType":"XenServer"},"dataStore":{"org.apache.cloudstack.storage.to.PrimaryDataStoreTO":{"uuid":"c65a038a-750c-3b4f-bf26-7ce3b74e1c85","id":2,"poolType":"NetworkFilesystem","host":"10.147.28.7","path":"/export/home/sanjeev/pri_xen_os","port":2049}},"vmName":"i-2-5-VM","name":"vm2-xen_test_20130816125908","hypervisorType":"XenServer","id":4}},"wait":0}}]
}
> createSnapshotCmd was executed via 1 , here 1 is the xenserver host.
> mysql> select id,name,hypervisor_type  from host where id=1;
> +----+-----------------+-----------------+
> | id | name            | hypervisor_type |
> +----+-----------------+-----------------+
> |  1 | Rack1Pod1Host14 | XenServer       |
> +----+-----------------+-----------------+
> 1 row in set (0.00 sec)
> Last update in SMlog is at :
> [root@Rack1Pod1Host14 log]# ls -altr SMlog*
> -rw------- 1 root root 535844 Aug 16 12:27 SMlog
> Time on xenserver when I filed this bug:
> [root@Rack1Pod1Host14 log]# date
> Fri Aug 16 13:23:21 UTC 2013
> There is no update in SMlog from 12:27 onwards.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message