cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jessica Wang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-4189) [UI] In multi zone setup, dedicating a single zone to a domain, shows other zones dedicated as well
Date Sat, 10 Aug 2013 02:05:47 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-4189?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13735681#comment-13735681
] 

Jessica Wang commented on CLOUDSTACK-4189:
------------------------------------------

I just checked in an UI change related to this bug, but my UI change is not the cause of this
bug.

The bug is caused by API => listDedicatedZones API fails to take in zoneid.
listDedicatedZones API should be able to take in zoneid and return only dedicatedzone whose
zoneid matches it.

As you can see in the following API calls, UI passes zoneid "8605b683-4c48-47d8-941a-b21f28a96b0c"
to listDedicatedZones API, 
and it returns a dedicated zone whose zoneid is "ab8b4db5-589e-42f1-83d0-93233b37165c" (doesn't
match).

===================================================================================================

http://10.216.133.43:8080/client/api?command=listZones&response=json&sessionkey=5qnq5%2FGsGxAKeOoHDeD8UlgRze8%3D&id=8605b683-4c48-47d8-941a-b21f28a96b0c&_=1376099460420
{
    "listzonesresponse": {
        "count": 1,
        "zone": [
            {
                "id": "8605b683-4c48-47d8-941a-b21f28a96b0c",
                "name": "Adv-vmware",
                "dns1": "10.103.128.16",
                "internaldns1": "10.103.128.16",
                "guestcidraddress": "10.1.1.0/24",
                "networktype": "Advanced",
                "securitygroupsenabled": false,
                "allocationstate": "Enabled",
                "zonetoken": "c500fa41-c65c-33a8-8da1-5b3ee8e5912d",
                "dhcpprovider": "VirtualRouter",
                "localstorageenabled": false
            }
        ]
    }
}

http://10.216.133.43:8080/client/api?command=listDedicatedZones&response=json&sessionkey=5qnq5%2FGsGxAKeOoHDeD8UlgRze8%3D&zoneid=8605b683-4c48-47d8-941a-b21f28a96b0c&_=1376099460505
{
    "listdedicatedzonesresponse": {
        "count": 1,
        "dedicatedzone": [
            {
                "id": "d1c55673-16e3-4a4f-9fd0-36cd7efd6069",
                "zoneid": "ab8b4db5-589e-42f1-83d0-93233b37165c",
                "zonename": "dedicatedZone",
                "domainid": "8cb207cb-fd82-4f0e-938b-b4cbfd82b3bf",
                "accountid": "35f84bd5-0931-459e-b190-a5a60aa15ed2"
            }
        ]
    }
}


                
> [UI] In multi zone setup, dedicating a single zone to a domain, shows other zones dedicated
as well
> ---------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-4189
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-4189
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: UI
>    Affects Versions: 4.2.0
>         Environment: Xenserver
>            Reporter: Saksham Srivastava
>            Assignee: Jessica Wang
>            Priority: Critical
>             Fix For: 4.2.0
>
>
> Steps to reproduce:
> 1) Create 2 zone setup z1 and z2,
> 2) Dedicate z1 to domain d1 through UI
> Observed Behavior: UI shows both zones as dedicated.
> The issue is only in UI,
> listDedicatedZone API shows only single zone(z1)
> dedicated_resources table also has the correct entry of the dedicated zone.
> Expected Behavior : Only zone dedicated should be listed as dedicated. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message