cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jessica Wang (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-4134) UI dosent fire the API with the Vlan values if the Vlan range is blank.
Date Sat, 10 Aug 2013 00:31:48 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-4134?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jessica Wang resolved CLOUDSTACK-4134.
--------------------------------------

    Resolution: Fixed

just checked in a UI change.

UI now pass vlan parameter to updatePhysicalNetwork API even vlan field is blank:

http://10.216.133.43:8080/client/api?command=updatePhysicalNetwork&response=json&sessionkey=y%2Br4nq0sSa3X%2B4jmr%2FJaF29T8h8%3D&id=05cd28d2-563a-421b-b76c-8450a1b8387a&vlan=&tags=aaa&_=1376094493139

However, API side ignores the blank vlan parameter.
Please have someone to fix it at API side.
                
> UI dosent fire the API with the Vlan values if the Vlan range is blank.
> -----------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-4134
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-4134
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: UI
>    Affects Versions: 4.2.0
>            Reporter: Kiran Koneti
>            Assignee: Jessica Wang
>            Priority: Critical
>             Fix For: 4.2.0
>
>
> When we try to edit the Vlan range from the UI and give blank values in the Vlan range
box and try to update the page the API fried doesn't have any Vlan details as it is blank
in the UI.
> Eg:
> I tried the below scenario:
> 1)Created a setup with the Vlan range 1100-1109.
> 2)Then created a network where the Vlan 1101 is associated with the network.
> 3)Now I tried to edit the Vlan range and gave the blank value in the UI and clicked update.
> The API fired is as below
> "10.147.38.237:8080/client/api?command=updatePhysicalNetwork&response=json&sessionkey=RRxhiAqmggnl%2F5oBGHNTm3DMj0M%3D&id=2409aeac-789a-4430-a9b7-fab66eb4b85c&_=1375867127326"
> Here the Vlan details are not fired in the API.
> Then I tried to edit it by giving the value 1102-1109  and  the API fired was as below:
> "http://10.147.38.237:8080/client/api?command=updatePhysicalNetwork&response=json&sessionkey=RRxhiAqmggnl%2F5oBGHNTm3DMj0M%3D&id=2409aeac-789a-4430-a9b7-fab66eb4b85c&vlan=1102-1109&_=1375867287606"
> The API was fired currently with the Vlan values and there was a error message as below
> "physicalnetwork 200 has allocated vnets in the range 1100-1101 " the below is the expected
behaviour and the same should happen when we try to update the UI with Blank details.
> Note: Even the UI doesn't popup with any error message the Vlan range is not getting
deleted and we can see the same vlan range once we refresh the page.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message