cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <>
Subject [jira] [Commented] (CLOUDSTACK-4134) UI dosent fire the API with the Vlan values if the Vlan range is blank.
Date Sat, 10 Aug 2013 00:27:48 GMT


ASF subversion and git services commented on CLOUDSTACK-4134:

Commit 24ef5ba9f7a9634ac11192aa02dba578a6757d3c in branch refs/heads/master from [~jessicawang]
[;h=24ef5ba ]

CLOUDSTACK-4134: UI > Infrastructure > zone > physical network > guest > edit
action - pass vlan parameter to updatePhysicalNetwork API no matter vlan field is blank or

> UI dosent fire the API with the Vlan values if the Vlan range is blank.
> -----------------------------------------------------------------------
>                 Key: CLOUDSTACK-4134
>                 URL:
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: UI
>    Affects Versions: 4.2.0
>            Reporter: Kiran Koneti
>            Assignee: Jessica Wang
>            Priority: Critical
>             Fix For: 4.2.0
> When we try to edit the Vlan range from the UI and give blank values in the Vlan range
box and try to update the page the API fried doesn't have any Vlan details as it is blank
in the UI.
> Eg:
> I tried the below scenario:
> 1)Created a setup with the Vlan range 1100-1109.
> 2)Then created a network where the Vlan 1101 is associated with the network.
> 3)Now I tried to edit the Vlan range and gave the blank value in the UI and clicked update.
> The API fired is as below
> ""
> Here the Vlan details are not fired in the API.
> Then I tried to edit it by giving the value 1102-1109  and  the API fired was as below:
> ""
> The API was fired currently with the Vlan values and there was a error message as below
> "physicalnetwork 200 has allocated vnets in the range 1100-1101 " the below is the expected
behaviour and the same should happen when we try to update the UI with Blank details.
> Note: Even the UI doesn't popup with any error message the Vlan range is not getting
deleted and we can see the same vlan range once we refresh the page.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message