cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kiran Koneti (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-4134) UI dosent fire the API with the Vlan values if the Vlan range is blank.
Date Wed, 07 Aug 2013 09:32:48 GMT
Kiran Koneti created CLOUDSTACK-4134:
----------------------------------------

             Summary: UI dosent fire the API with the Vlan values if the Vlan range is blank.
                 Key: CLOUDSTACK-4134
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-4134
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: UI
    Affects Versions: 4.2.0
            Reporter: Kiran Koneti
            Priority: Critical
             Fix For: 4.2.0


When we try to edit the Vlan range from the UI and give blank values in the Vlan range box
and try to update the page the API fried doesn't have any Vlan details as it is blank in the
UI.

Eg:
I tried the below scenario:
1)Created a setup with the Vlan range 1100-1109.
2)Then created a network where the Vlan 1101 is associated with the network.
3)Now I tried to edit the Vlan range and gave the blank value in the UI and clicked update.

The API fired is as below
"10.147.38.237:8080/client/api?command=updatePhysicalNetwork&response=json&sessionkey=RRxhiAqmggnl%2F5oBGHNTm3DMj0M%3D&id=2409aeac-789a-4430-a9b7-fab66eb4b85c&_=1375867127326"

Here the Vlan details are not fired in the API.

Then I tried to edit it by giving the value 1102-1109  and  the API fired was as below:

"http://10.147.38.237:8080/client/api?command=updatePhysicalNetwork&response=json&sessionkey=RRxhiAqmggnl%2F5oBGHNTm3DMj0M%3D&id=2409aeac-789a-4430-a9b7-fab66eb4b85c&vlan=1102-1109&_=1375867287606"

The API was fired currently with the Vlan values and there was a error message as below

"physicalnetwork 200 has allocated vnets in the range 1100-1101 " the below is the expected
behaviour and the same should happen when we try to update the UI with Blank details.


Note: Even the UI doesn't popup with any error message the Vlan range is not getting deleted
and we can see the same vlan range once we refresh the page.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message