cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "venkata swamybabu budumuru (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (CLOUDSTACK-3099) [ResourceDetail APIs] There is no API (deleteResourceDetail) available for deleting the resource details
Date Wed, 07 Aug 2013 11:01:48 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-3099?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

venkata swamybabu budumuru closed CLOUDSTACK-3099.
--------------------------------------------------


This API was mentioned wrongly in the FS. I checked for right one which removeResourceDetails.
This API is working fine as expected. Closing this bug.
                
> [ResourceDetail APIs] There is no API (deleteResourceDetail) available for deleting the
resource details
> --------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-3099
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-3099
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.2.0
>         Environment: commit # 971c40d98e07ab6cddb8e6db5095c1acea935815
>            Reporter: venkata swamybabu budumuru
>            Assignee: Nitin Mehta
>            Priority: Minor
>             Fix For: 4.2.0
>
>         Attachments: logs.tgz
>
>
> Steps to reproduce:
> 1. Have CloudStack setup with at least one advanced zone
> 2. verify whether listAPIs show the API for deleting the resource details (deleteResourceDetail)
> Observations:
> (i) http://10.147.59.194:8096/api?command=listApis&name=deleteResourceDetail
> <listapisresponse cloud-stack-version="4.2.0-SNAPSHOT"><errorcode>530</errorcode><cserrorcode>9999</cserrorcode><errortext>Api
Discovery plugin was unable to find an api by that name or process any apis</errortext></listapisresponse>
> (ii) Tried to fire the API and it as well failed with the same error
> http://10.147.59.194:8096/api?command=deleteResourceDetail
> <errorresponse cloud-stack-version="4.2.0-SNAPSHOT"><errorcode>432</errorcode><cserrorcode>9999</cserrorcode><errortext>Unknown
API command: deleteResourceDetail</errortext></errorresponse>
> (iii) Functional Spec sates that we will have it in CloudStack but, it is not available.

> Here is the link for FS : https://cwiki.apache.org/confluence/display/CLOUDSTACK/Ability+to+have+better+control+over+first+class+objects+in+CS

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message