cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jayapal Reddy (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-3843) router VM not setting Password for all the VMs in case of parallel deployment with password enabled template
Date Mon, 29 Jul 2013 11:13:48 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-3843?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jayapal Reddy resolved CLOUDSTACK-3843.
---------------------------------------

    Resolution: Fixed
    
> router VM not setting Password for all the VMs in case of parallel deployment with password
enabled template 
> -------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-3843
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-3843
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.2.0
>         Environment: Build:
> CloudPlatform-4.2-257-rhel6.3.tar.gz
> MS : advanced zone with KVM host
>            Reporter: shweta agarwal
>            Assignee: Jayapal Reddy
>            Priority: Critical
>             Fix For: 4.2.0
>
>         Attachments: agent.log.tar.gz, management-server.tar.gz
>
>
> Repro steps:
> Create a password enables template 
> Deploy 30-50 vms using this template
> Bug:
> All VMs is not getting passwords
> Router VM in password files shows entries for only 21 VM though i deployed 30 VMs
> vi /var/cache/cloud/passwords 
> 10.1.1.75=nW7jdwray
> 10.1.1.103=nI9qcbdjs
> 10.1.1.171=xS5mhsgwk
> 10.1.1.155=yN5wjywuy
> 10.1.1.80=kQ5pgykmw
> 10.1.1.6=zS2vpgrgg
> 10.1.1.197=sV9nbkrgf
> 10.1.1.198=zC2mrhxcw
> 10.1.1.97=jP5fzqmtk
> 10.1.1.191=nI3vcwrup
> 10.1.1.45=saved_password
> 10.1.1.14=saved_password
> 10.1.1.175=saved_password
> 10.1.1.77=saved_password
> 10.1.1.221=saved_password
> 10.1.1.183=saved_password
> 10.1.1.121=saved_password
> 10.1.1.108=saved_password
> 10.1.1.69=saved_password
> 10.1.1.2=saved_password
> 10.1.1.32=saved_password
> Acces logs of router VM shows  full 30 entries :
> 10.1.1.45 - - [26/Jul/2013:04:42:06 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.14 - - [26/Jul/2013:04:42:07 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.75 - - [26/Jul/2013:04:42:13 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.67 - - [26/Jul/2013:04:42:13 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.61 - - [26/Jul/2013:04:42:14 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.175 - - [26/Jul/2013:04:42:17 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.65 - - [26/Jul/2013:04:42:29 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.103 - - [26/Jul/2013:04:42:30 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.27 - - [26/Jul/2013:04:42:30 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.77 - - [26/Jul/2013:04:42:58 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.171 - - [26/Jul/2013:04:42:59 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.221 - - [26/Jul/2013:04:43:00 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.183 - - [26/Jul/2013:04:43:00 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.121 - - [26/Jul/2013:04:43:05 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.108 - - [26/Jul/2013:04:43:09 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.23 - - [26/Jul/2013:04:43:14 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.197 - - [26/Jul/2013:04:43:14 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.80 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.219 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.198 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.155 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.191 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.97 - - [26/Jul/2013:04:43:16 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.6 - - [26/Jul/2013:04:43:16 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.69 - - [26/Jul/2013:04:43:16 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.2 - - [26/Jul/2013:04:43:19 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.234 - - [26/Jul/2013:04:43:19 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.218 - - [26/Jul/2013:04:43:19 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.32 - - [26/Jul/2013:04:43:20 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.209 - - [26/Jul/2013:05:32:27 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> So there are two issues 
> First for all VMs entries are not there in router vm password file
> Second even for those whose entries are there for almost 50% of them failed to get actual
password. 
> ~

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message