cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jayapal Reddy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-3843) router VM not setting Password for all the VMs in case of parallel deployment with password enabled template
Date Sun, 28 Jul 2013 06:55:48 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-3843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13721899#comment-13721899
] 

Jayapal Reddy commented on CLOUDSTACK-3843:
-------------------------------------------

Not reproduced the issue in my setup.


root@r-12-QA:~# cat /var/cache/cloud/passwords
10.1.1.38=saved_password
10.1.1.69=saved_password
10.1.1.21=saved_password
10.1.1.172=saved_password
10.1.1.249=saved_password
10.1.1.129=saved_password
10.1.1.18=saved_password
10.1.1.215=saved_password
10.1.1.142=saved_password
10.1.1.197=saved_password
10.1.1.160=saved_password
10.1.1.178=saved_password
10.1.1.174=saved_password
10.1.1.104=saved_password
10.1.1.157=saved_password
10.1.1.125=saved_password
10.1.1.39=saved_password
10.1.1.103=saved_password
10.1.1.188=saved_password
10.1.1.86=saved_password
10.1.1.217=saved_password
10.1.1.158=saved_password
10.1.1.31=saved_password
10.1.1.214=saved_password
10.1.1.185=saved_password
10.1.1.11=saved_password
10.1.1.78=saved_password
10.1.1.194=uX8jbprzk
10.1.1.61=qB5jdhriv
10.1.1.95=nU4vnpikz
10.1.1.29=eK7itsprz
10.1.1.208=aS9tgkxin
10.1.1.189=wM3ptncic
10.1.1.70=qI7syceis
10.1.1.251=kG8bcezkb
10.1.1.114=vK2qfbtpv
10.1.1.143=zJ5ynyxxg
10.1.1.228=gX6ftjfdm
10.1.1.165=jT8rbfntp
10.1.1.244=gG7epivgg
10.1.1.68=fZ8sjntme
10.1.1.5=mA6pagwdc
10.1.1.254=bF8kyrkuy
10.1.1.222=iE7wfwwkf
10.1.1.132=dI7pnxbik
10.1.1.33=vH2neifnb
10.1.1.224=yP6gyuntk
10.1.1.211=wA6mmxkzf
10.1.1.152=gV2stmmmm
10.1.1.140=uZ2utumns
10.1.1.179=nU7frsbyf
10.1.1.192=gR6yteizu
10.1.1.198=xY5cvatse
10.1.1.234=wG6caypdy
10.1.1.181=pG5mfryur
10.1.1.106=eA4ybasbi
10.1.1.26=pR7fcjecf
10.1.1.136=gH9psxdix
10.1.1.30=kG6edcwxa
10.1.1.4=cV5mdqgfe


mysql> SELECT instance_name, private_ip_address FROM cloud.vm_instance where state='Running'
and type='User';
+---------------+--------------------+
| instance_name | private_ip_address |
+---------------+--------------------+
| i-2-54-QA     | 10.1.1.194         |
| i-2-55-QA     | 10.1.1.61          |
| i-2-56-QA     | 10.1.1.95          |
| i-2-57-QA     | 10.1.1.29          |
| i-2-58-QA     | 10.1.1.208         |
| i-2-59-QA     | 10.1.1.189         |
| i-2-60-QA     | 10.1.1.70          |
| i-2-61-QA     | 10.1.1.251         |
| i-2-62-QA     | 10.1.1.114         |
| i-2-63-QA     | 10.1.1.143         |
| i-2-64-QA     | 10.1.1.228         |
| i-2-65-QA     | 10.1.1.165         |
| i-2-66-QA     | 10.1.1.5           |
| i-2-67-QA     | 10.1.1.68          |
| i-2-68-QA     | 10.1.1.244         |
| i-2-69-QA     | 10.1.1.211         |
| i-2-70-QA     | 10.1.1.224         |
| i-2-71-QA     | 10.1.1.33          |
| i-2-72-QA     | 10.1.1.132         |
| i-2-73-QA     | 10.1.1.222         |
| i-2-74-QA     | 10.1.1.254         |
| i-2-75-QA     | 10.1.1.4           |
| i-2-76-QA     | 10.1.1.30          |
| i-2-77-QA     | 10.1.1.136         |
| i-2-78-QA     | 10.1.1.26          |
| i-2-79-QA     | 10.1.1.106         |
| i-2-80-QA     | 10.1.1.181         |
| i-2-81-QA     | 10.1.1.234         |
| i-2-82-QA     | 10.1.1.198         |
| i-2-83-QA     | 10.1.1.192         |
| i-2-84-QA     | 10.1.1.179         |
| i-2-85-QA     | 10.1.1.140         |
+---------------+--------------------+
                
> router VM not setting Password for all the VMs in case of parallel deployment with password
enabled template 
> -------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-3843
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-3843
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.2.0
>         Environment: Build:
> CloudPlatform-4.2-257-rhel6.3.tar.gz
> MS : advanced zone with KVM host
>            Reporter: shweta agarwal
>            Assignee: Jayapal Reddy
>            Priority: Critical
>             Fix For: 4.2.0
>
>         Attachments: agent.log.tar.gz, management-server.tar.gz
>
>
> Repro steps:
> Create a password enables template 
> Deploy 30-50 vms using this template
> Bug:
> All VMs is not getting passwords
> Router VM in password files shows entries for only 21 VM though i deployed 30 VMs
> vi /var/cache/cloud/passwords 
> 10.1.1.75=nW7jdwray
> 10.1.1.103=nI9qcbdjs
> 10.1.1.171=xS5mhsgwk
> 10.1.1.155=yN5wjywuy
> 10.1.1.80=kQ5pgykmw
> 10.1.1.6=zS2vpgrgg
> 10.1.1.197=sV9nbkrgf
> 10.1.1.198=zC2mrhxcw
> 10.1.1.97=jP5fzqmtk
> 10.1.1.191=nI3vcwrup
> 10.1.1.45=saved_password
> 10.1.1.14=saved_password
> 10.1.1.175=saved_password
> 10.1.1.77=saved_password
> 10.1.1.221=saved_password
> 10.1.1.183=saved_password
> 10.1.1.121=saved_password
> 10.1.1.108=saved_password
> 10.1.1.69=saved_password
> 10.1.1.2=saved_password
> 10.1.1.32=saved_password
> Acces logs of router VM shows  full 30 entries :
> 10.1.1.45 - - [26/Jul/2013:04:42:06 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.14 - - [26/Jul/2013:04:42:07 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.75 - - [26/Jul/2013:04:42:13 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.67 - - [26/Jul/2013:04:42:13 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.61 - - [26/Jul/2013:04:42:14 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.175 - - [26/Jul/2013:04:42:17 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.65 - - [26/Jul/2013:04:42:29 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.103 - - [26/Jul/2013:04:42:30 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.27 - - [26/Jul/2013:04:42:30 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.77 - - [26/Jul/2013:04:42:58 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.171 - - [26/Jul/2013:04:42:59 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.221 - - [26/Jul/2013:04:43:00 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.183 - - [26/Jul/2013:04:43:00 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.121 - - [26/Jul/2013:04:43:05 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.108 - - [26/Jul/2013:04:43:09 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.23 - - [26/Jul/2013:04:43:14 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.197 - - [26/Jul/2013:04:43:14 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.80 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.219 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.198 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.155 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.191 - - [26/Jul/2013:04:43:15 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.97 - - [26/Jul/2013:04:43:16 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.6 - - [26/Jul/2013:04:43:16 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.69 - - [26/Jul/2013:04:43:16 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.2 - - [26/Jul/2013:04:43:19 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.234 - - [26/Jul/2013:04:43:19 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.218 - - [26/Jul/2013:04:43:19 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.32 - - [26/Jul/2013:04:43:20 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> 10.1.1.209 - - [26/Jul/2013:05:32:27 +0000] "GET /latest/public-keys HTTP/1.0" 200 285
"-" "Wget/1.11.4 Red Hat modified"
> So there are two issues 
> First for all VMs entries are not there in router vm password file
> Second even for those whose entries are there for almost 50% of them failed to get actual
password. 
> ~

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message