cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkata Siva Vijayendra Bhamidipati (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-3600) [Automation][BVT] Failed to delete and extract "ISO" in vmware
Date Thu, 18 Jul 2013 01:50:48 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-3600?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13711920#comment-13711920
] 

Venkata Siva Vijayendra Bhamidipati commented on CLOUDSTACK-3600:
-----------------------------------------------------------------

I just tried these two operations on the latest 4.2 branch. The ExtractIsoCmd API fired when
we attempt to download an uploaded ISO works fine for me. I am not sure why the above NPE
showed up in the above run. It is possible that the issue might have been fixed in later commits
on 4.2.

Next, when I attempt to delete a template created from a root volume, I don't run into an
exception, though I run into a failure. The first time, the UI gives a failure message, probably
because when it does a list templates, it still finds the template there. However, the logs
show this:


INFO  [cloud.template.HypervisorTemplateAdapter] (Job-Executor-5:job-36 = [ 552300c6-ec62-49db-a74e-3531dbb1ec9c
]) Delete template from image store: s1
WARN  [cloud.template.HypervisorTemplateAdapter] (Job-Executor-5:job-36 = [ 552300c6-ec62-49db-a74e-3531dbb1ec9c
]) Failed to delete the template Tmpl[206-OVA-2cb7e13c2-3c44-36d0-b8cd-a9017e073ec0 from the
image store: s1 due to: Unable to delete file template under Template path 2cb7e13c2-3c44-36d0-b8cd-a9017e073ec0
INFO  [cloud.template.HypervisorTemplateAdapter] (Job-Executor-6:job-37 = [ 23075f1f-06aa-4870-be35-41b73ebee6ef
]) Unable to find image store still having template: vm1template1, so just mark the template
removed
INFO  [cloud.template.HypervisorTemplateAdapter] (Job-Executor-6:job-37 = [ 23075f1f-06aa-4870-be35-41b73ebee6ef
]) Delete template from template table


The template is marked removed, so if I retry the same operation a second time, the template
is deleted. But it still seems to be resident on secondary storage:

[root@nfs2 tmpl]# find . | grep -i "2cb7e"
./2/206/2cb7e13c2-3c44-36d0-b8cd-a9017e073ec0.ovf
./2/206/2cb7e13c2-3c44-36d0-b8cd-a9017e073ec0.ova
./2/206/2cb7e13c2-3c44-36d0-b8cd-a9017e073ec0-disk0.vmdk
[root@nfs2 tmpl]#


Need to investigate further to see why the template is not being found. Looks like the template
path isn't being built correctly - probably the imagestore isn't being set correctly?

I think this issue can be made critical/major instead of a blocker since I don't run into
the above exceptions with the latest master.
                
> [Automation][BVT] Failed to delete and extract "ISO" in vmware 
> ---------------------------------------------------------------
>
>                 Key: CLOUDSTACK-3600
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-3600
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: ISO
>    Affects Versions: 4.2.0
>         Environment: VMware
> Build 4.2
>            Reporter: Rayees Namathponnan
>            Assignee: Venkata Siva Vijayendra Bhamidipati
>            Priority: Blocker
>             Fix For: 4.2.0
>
>
> BVT failure 
> integration.smoke.test_iso.TestISO.test_03_delete_iso
> Unaable to delete iso observed below error in MS log
> INFO  [cloud.template.HypervisorTemplateAdapter] (Job-Executor-15:job-1591 = [ 903c440e-7f7c-4151-9258-88fa82c1d05c
]) Delete template from image store: nfs://10.223.110.232:/export/home/automation/SC-CLOUD-QA03/secondary1
> ERROR [cloud.async.AsyncJobManagerImpl] (Job-Executor-15:job-1591 = [ 903c440e-7f7c-4151-9258-88fa82c1d05c
]) Unexpected exception while executing org.apache.cloudstack.api.command.user.template.DeleteTemplateCmd
> com.cloud.utils.exception.CloudRuntimeException: Failed to update state
>         at org.apache.cloudstack.storage.image.store.TemplateObject.processEvent(TemplateObject.java:164)
>         at org.apache.cloudstack.storage.image.TemplateServiceImpl.deleteTemplateAsync(TemplateServiceImpl.java:513)
>         at com.cloud.template.HypervisorTemplateAdapter.delete(HypervisorTemplateAdapter.java:242)
>         at com.cloud.utils.component.ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept(ComponentInstantiationPostProcessor.java:125)
>         at com.cloud.template.TemplateManagerImpl.deleteTemplate(TemplateManagerImpl.java:1063)
>         at com.cloud.utils.component.ComponentInstantiationPostProcessor$InterceptorDispatcher.intercept(ComponentInstantiationPostProcessor.java:125)
>         at org.apache.cloudstack.api.command.user.template.DeleteTemplateCmd.execute(DeleteTemplateCmd.java:112)
>         at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:158)
>         at com.cloud.async.AsyncJobManagerImpl$1.run(AsyncJobManagerImpl.java:531)
>         at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
>         at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:166)
>         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
>         at java.lang.Thread.run(Thread.java:722)
> Caused by: com.cloud.utils.fsm.NoTransitionException: Unable to transition to a new state
from Creating via DestroyRequested
>         at com.cloud.utils.fsm.StateMachine2.getNextState(StateMachine2.java:83)
>         at com.cloud.utils.fsm.StateMachine2.transitTo(StateMachine2.java:100)
>         at org.apache.cloudstack.storage.datastore.ObjectInDataStoreManagerImpl.update(ObjectInDataStoreManagerImpl.java:236)
>         at org.apache.cloudstack.storage.image.store.TemplateObject.processEvent(TemplateObject.java:162)
>         ... 22 more

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message