cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rajesh Battala (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-2882) [Automation] [KVM]Test case "test_vm_life_cycle.TestVMLifeCycle.test_10_attachAndDetach_iso" failing due to wrong mount point
Date Sat, 27 Jul 2013 13:37:48 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-2882?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13721622#comment-13721622
] 

Rajesh Battala commented on CLOUDSTACK-2882:
--------------------------------------------

This issue is with the script. and attach iso working fine.

issue in the script is:
=============== 
when I had attached the iso (http://people.apache.org/~tsp/dummy.iso) to the instance created
from the default centos template on Kvm. 
the iso got attached and got detected by instance with the device file as  /dev/hdc
posted the kvm agent log below.
but in script its checking with the device file as "/dev/vdb " which is hardcoded value. 
disks are getting created with device files like /dev/vd[a-z]

I had tried manually to execute the steps in the script for test 10, and it worked without
any issue.

As sateesh mentioned in the above comment 
For IDE disks - /dev/hdX, where X ranges from a-z
For SCSI disks - /dev/sdX, where X ranges from a-z

we should iterate for range with /dev/hd[a-z] or /dev/vd[a-z] depending upon guest para-virtulization
type. 

in the BVT environment if the default centOS template is used to test this feature, please
use the above notation to mount the device which will resolve the issue.




<name>f22ee33b-9f2a-3d2e-9cc5-1b3a27d2f7e2</name>
<uuid>f22ee33b-9f2a-3d2e-9cc5-1b3a27d2f7e2</uuid>
<source>
<host name='10.102.192.100'/>
<dir path='/cpg_vol/rajesh/secondary/template/tmpl/2/202'/>
</source>
<target>
<path>/mnt/f22ee33b-9f2a-3d2e-9cc5-1b3a27d2f7e2</path>
</target>
</pool>

2013-07-27 18:48:33,879 DEBUG [kvm.storage.KVMStorageProcessor] (agentRequest-Handler-3:null)
Attaching device: <disk  device='cdrom' type='file'>
<driver name='qemu' type='raw' cache='none' />
<source file='/mnt/f22ee33b-9f2a-3d2e-9cc5-1b3a27d2f7e2/202-2-55619b3b-22a1-393f-932d-c1129ac7d58a.iso'/>
<target dev='hdc' bus='ide'/>
</disk>
                
> [Automation] [KVM]Test case "test_vm_life_cycle.TestVMLifeCycle.test_10_attachAndDetach_iso"
failing due to wrong mount point 
> ------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-2882
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-2882
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Automation
>    Affects Versions: 4.2.0
>         Environment: Automation - BVT 
>            Reporter: Rayees Namathponnan
>            Assignee: Rajesh Battala
>            Priority: Blocker
>             Fix For: 4.2.0
>
>
> Test case "test_vm_life_cycle.TestVMLifeCycle.test_10_attachAndDetach_iso" failing due
to wrong mount point in KVM
> Test case failing with below error
> paramiko.transport: INFO: Secsh channel 3 opened.
> paramiko.transport: DEBUG: [chan 3] Sesch channel 3 request ok
> sshClient: DEBUG: {Cmd: mount -rt iso9660 /dev/xvdd /mnt/tmp via Host: 10.208.10.22}
{returns: ['mount: special device /dev/xvdd does not exist']}
> http://jenkins.cloudstack.org/view/cloudstack-qa/job/test-smoke-matrix/389/suite=test_vm_life_cycle/testReport/integration.smoke.test_vm_life_cycle/TestVMLifeCycle/test_10_attachAndDetach_iso/

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message